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Chapter 1: Introduction
This document contains information on using Wavelink Remote Control 
(Remote Control), an Avalanche plug-in software package. 

About This Document

This section describes the assumptions behind this document and the 
typographical conventions used in this document.

Document Assumptions

• The user is comfortable in a Windows application environment.

• The user is familiar with the wireless hardware in use, specifically the 
mobile device.

• The user is familiar with the Avalanche system environment.

Document Conventions

This document uses the following typographical conventions:

• Courier New. Any time you interact with a Wavelink Remote Control 
option, such as a button, or type specific information into an text box, such 
as a file pathname, that option appears in the Courier New text style. 
This text style is also used for keyboard commands that you press.

Examples:

Click Next to continue. 

Press CTRL+ALT+DELETE.

• Bold. Any time this document refers to an option, such as descriptions of 
the choices in a dialog box, that option appears in the Bold text style.

Examples:

Click Open from the File menu.

Click Download from the HexFiles menu.
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• Italics. Any time this document refers to another section within the 
manual, that section appears in the Italic text style.

Example:

See the Troubleshooting section for possible causes of this problem.

Remote Control Overview

Remote Control gives you the ability to view and control your Windows CE 
mobile device from your Avalanche Management Console or Avalanche MC 
Console and provides real-time images of your mobile device in either 
Console. 

With the Avalanche Remote Control plug-in, an administrator can remotely 
diagnose and remedy both applications and device settings, or simply 
provide assisted guidance for an end-user. This reduces mobile device down-
time and increases end-user productivity. Remote Control can be used for 
presenting software to an audience, rapid data entry and automated software 
testing.

Remote Control allows multiple instances of itself to run. Each instance can 
control a separate device. If using a LAN connection for more than one 
device, each copy of Remote Control must be started and connected to a 
device before another is started. 

Supported Devices

All windows CE-based mobile devices with an Avalanche 3.x Enabler are 
supported.

Features of Remote Control

The following list describes just some of the features available in Remote 
Control:

• Ability for 18 frames per second capture speed (depending on the device 
and the method of communication

• Support for ActiveSync and wireless LAN

• Capture session to a standard AVI file for distribution
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• Create your own scripts to control your CE device including, launching 
applications remotely

• Minimal impact on target device CPU while capturing

• One-click capture of snapshot of the CE screen to the clipboard or a .bmp, 
.gif, or .jpeg file

• Auto-discovery of the target devices on a LAN

• Password protection of LAN-connected devices

• Support for custom skins

• Multiple instances can run allowing multiple devices to be controlled 
simultaneously

Wavelink Remote Control Console

The Remote Control package installs on the Avalanche Manager or the 
Avalanche MC Console and then the client portion of Remote Control is 
downloaded to the mobile device. You can access the Wavelink Remote 
Control console from the Avalanche Manager console or from the Avalanche 
MC Console. 

The Wavelink Remote Control console on the server-side allows you to 
configure default settings, connection settings, client-side settings, and client-
run scenarios.

Wavelink Remote Control Client

Once you download the Remote Control package to the mobile device, you 
can configure a limited number of client-side settings. 

The client portion of the Wavelink Remote Control package is deployed as an 
Avalanche package and runs automatically upon start-up or boot of the 
mobile device. Wavelink Remote Control can also be launched from the 
Programs screen of the Avalanche Enabler.

Distribution

Wavelink Remote Control is only distributed as an Avalanche package. For 
more information contact Wavelink Customer Support. 
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Chapter 2: Installing Wavelink Remote 
Control

The Wavelink Remote Control is installed in the Avalanche Management 
Console or Avalanche MC Console and then configured before being 
deployed to a mobile device.

This chapter provides the following installation information:

• System Requirements

• Installing Remote Control Software Packages

System Requirements

The following elements are required to install and run Wavelink Remote 
Control:

• Server Requirements

• Client Requirements

• Connection Requirements

Server Requirements

• Avalanche Manager 3.3.0.1 or later versions

-or-

• Avalanche Mobility Center 4.01 or later versions

• 5 MB of disk space

Client Requirements

• Avalanche Enabler 3.x

• Windows CE (PocketPC 2003, .NET 4.2, Windows Mobile 5.0)

• 200 KB of disk space

• 200 KB of Flash memory 
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Connection Requirements

• IP Connectivity (for Lan/Internet connections)

• ActiveSync (for ActiveSync connections)

NOTE To obtain the Wavelink Remote Control installation package, contact 
Wavelink Customer Support. For more information, refer to Appendix A: 
Wavelink Contact Information on page 137.

Installing Remote Control Software Packages

The Remote Control is an Avalanche software package that you can install in 
Avalanche Manager or Avalanche MC.

Avalanche Manager Installation

The following tasks are required to install Wavelink Remote Control in the 
Avalanche Manager:

1 Connecting to the Avalanche Agent

2 Installing the Remote Control Software Package

Connecting to the Avalanche Agent

Before you can install the Remote Control software package you must connect 
to the Avalanche Agent.

To connect to the Avalanche Agent:

1 Launch the Wavelink Avalanche Management Console.

2 From the Agent menu, select Connect to Agent.
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Figure 2-1. Connecting to the Agent

The Agent Connection Wizard dialog box appears.

Figure 2-2. Selecting an Avalanche Agent Connection

3 Select Use an existing agent connection.

4 Select an existing agent to connect to from the drop-down menu.

5 Click Next.
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If the Agent you are trying the connect to is not running, the Wizard 
displays a dialog box that allows you to start the Agent before proceeding. 
Once the Agent has started, click Next.

The Enter authentication information dialog box appears.

Figure 2-3. Entering Authentication Information

6 Enter authentication information.

If you want to connect to the Agent as an authorized user, enter a valid 
Username and Password. 

If you want to connect to the Agent with read-write guest authorization, 
leave the Username and Password text boxes blank. However, if 
authorization is required for the Agent, access to the Agent will be denied. 

NOTE If you connect to the Agent with read/write guest authorization, you 
will not be able to access the Remote Control Console or configure Wavelink 
Remote Control.

7 Click Next.
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The Agent Connection Wizard connects to the Agent. 

Figure 2-4. Connection to the Avalanche Agent

If the Agent is unable to connect, the message box will indicate that a 
connection could not be established. In this case, verify that you are using 
the correct IP address for the Agent and that the address is accessible on 
the LAN or WAN.

8 Click Finish.

Installing the Remote Control Software Package

Once you are connected to an Agent, you can install the Remote Control 
software package in Avalanche Manager. 

To install a software package:

1 From the Software Management menu, select Install Software 
Package.
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Figure 2-5. Installing the Software Package

The Install Software Package Wizard appears.

Figure 2-6. Selecting the Software Package

2 Type the path to the Remote Control software package or click Browse to 
navigate to the package.

3 From the drop-down list, select the software collection to which you want 
the Remote Control package to belong. 

4 Click Next.

5 Click Yes I agree to agree to the license agreement.
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If you click No, I disagree, you will not be able to continue the 
installation.

6 Click Next.

The Remote Control software package will be installed to the software 
collection you specified.

Figure 2-7. Completing Installation

7 Click Finish.

You can view the software package in the Tree View of the Avalanche 
Manager.

Installing Software Packages to Avalanche MC

Before you can install software packages in the Avalanche MC Console, you 
need to create a software collection. A software collection is a logical 
grouping of software packages that are maintained and managed by 
Avalanche MC. During package installation, the Avalanche MC allows you to 
create a new software collection for the package or add it to an existing 
collection. You can create new collections or copy software from collection to 
collection as needed. 
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This section provides information on the following tasks:

• Adding Software Collections

• Enabling Software Collections

• Installing Software Packages

• Enabling a Software Package

Adding Software Collections

You can add software collections from the Software Collections tab in the 
Avalanche MC Console. 

To add a software collection:

1 From the Avalanche MC Console, click the Software Collections tab.

2 Click New Collection.

-Or-

Right-click in the list box and select New Collection.

3 Enter the name of the collection and click OK.

The new collection appears in the Software Collection/Package Name list.

Enabling Software Collections

Before you add software packages to a software collection, you should enable 
the software collection.

To activate a software collection:

1 From the Avalanche MC console, select the Software Collections tab.

2 In the Software Collections/Package Name list, right-click on the desired 
collection and select Enable. 

Installing Software Packages 

Once you have created and enabled a software collection, you can install the 
Remote Control software package. This will allow you to configure the 
software package and then deploy the package to a mobile device. 
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To install a software package: 

1 From the Avalanche MC Console, click the Software Collections tab and 
then click Install Package.

The Install Software Package Wizard launches. 

2 Type the path to the software package in the text box provided, or click 
[...] to navigate to the Remote Control package.

This package must have an .ava extension. 

3 Click Next.

4 Select a software collection and click Next.

The Install Software Package Wizard installs the package to the specified 
software collection. 

5 Click Finish. 

NOTE Software packages are disabled when you first install them to prevent 
packages from downloading before they are properly configured.

NOTE Once you have installed the Remote Control package, you should 
activate the Remote Control license to ensure complete functionality. For 
more information about licensing, refer to Chapter 3: Licensing on page 19.

Enabling a Software Package 

Before you can deploy a software package to a mobile device, you must first 
enable it. Once you enable a software package, it will immediately download 
to the mobile device.

Wavelink recommends that you configure the Remote Control package before 
you enable it. This prevents packages from deploying to the mobile device 
before they are properly configured. For configuration information, refer to 
Chapter 3: Configuring Remote Control on page 25.

To enable a software package:

1 In the Avalanche MC Console, click the Software Collections tab.
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2 Right-click on the desired package in the Software Collection/Package 
Name list and select Enable.

The software package will be deployed to the mobile device.



Chapter 3: Licensing 19

Chapter 3: Licensing
Remote Control requires a license for full functionality. You can access and 
configure the Remote Control Console without a license, but you will not be 
able to communicate with a mobile device. 

Remote Control licensing is based on a per-mobile device. This means that 
Remote Control can manage one mobile device for each license.

This chapter provides the following licensing information:

• Types of Licenses

• Running the License Server

• Activating Remote Control

• Changing the License Server

• Verifying Licenses

Types of Licenses

Remote Control requires one Remote Control license for each mobile device 
to which you want to connect. 

NOTE To obtain any Remote Control license, please contact Wavelink 
Customer Support.

There are two types of licenses you can purchase for Remote Control:

• Base Licenses

• Maintenance Licenses

Base Licenses

A base license authorizes you to the version of Remote Control that you 
purchased and any builds associated with that version. For example, if you 
purchased a Remote Control 2.0 license, then you are entitled to use 2.00- xx 
Avalanche builds. If you want to use the features available in the 2.10- xx 
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Remote Control, then you must either buy a 2.1 base license for your mobile 
devices, or you must purchase a maintenance license for your devices. A Base 
license provides for minor upgrades and code changes, but does not allow 
major upgrades and updates to Remote Control. Base licenses do not expire, 
but they do not allow you to upgrade to a greater version of Remote Control.

Maintenance Licenses

A maintenance license allows you to upgrade Remote Control when new 
major versions of Remote Control become available. For example, a 
maintenance license allows you to upgrade from Remote Control 2.x to 
Remote Control 3.x. Maintenance licenses are valid only through a specific 
date. After the expiration date, if you upgrade Remote Control, it will revert 
to operating in demo mode.

Running the License Server

License Server is a Wavelink application that runs on a host system and as 
part of Avalanche MC and the Avalanche Manager software packages. The 
license server is responsible for supplying licenses to mobile devices that are 
using Remote Control.

When a Mobile Device Agent detects that a device is running Remote 
Control, it sends a request to the license server for that particular type of 
license. The License Server then sends down the Remote Control license to 
the requesting Agent. 

If a license expires or is released, the license returns to the pool of licenses in 
the License Server until it is sent to an agent upon request.

The License Server is a service that starts automatically. However, if for some 
reason the Server is not running, the mobile device will not be able receive 
licenses. 

The License Server operates on port 7221. For the License Server to function 
properly, this port needs to be open or not blocked by firewall.
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Running the License Server from the Command Line

Use the following switches to run the license server from a command line:

Activating Remote Control

After you install the Remote Control software package, you are asked to 
activate it with a valid license code. This code uses a technique called 
nodelocking, in which Remote Control is licensed only for a specific computer, 
or node, on your network. A node is defined as several specific system 
attributes that, in combination, uniquely distinguish it from any other system 
in your organization.

Once a license for Remote Control is activated and associated with a specific 
node (nodelocked), you can not move that license to another node. If you 
want to move the license, you need to contact Wavelink Customer Service.

This section provides the following information about activating your Remote 
Control license:

• Launching the Remote Control License Activator 

 -c Run as a console application, not as a service

-i   Install the license server

-q      Stop the license server

-s Start the license server

-u Uninstall the license server

 -l <level> Logging level

• d = debug

• n = notice (default)

• w = warn

•  e = error

•  c = critical
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• Activating Demo Mode

• Activating Remote Control Licenses

Launching the Remote Control License Activator

Wavelink provides a license Activator packaged with Avalanche MC and 
with the Remote Control package. You can access this Activator to install 
licenses for Remote Control package.

Once you launch the Activator, the methods you use to run the activator and 
install licenses is the same whether you are using Avalanche MC or 
Avalanche Manager.

Launching the Activator in Avalanche MC

You can launch the activator from the Start menu or from the Remote Control 
software package if you are using Avalanche MC.

To launch the activator for Avalanche MC:

• Select Start > Programs > AvalancheMC > Activator.

-Or- 

• Right-click the Remote Control software package in the Software 
Collections tab of Avalanche MC and select Configure. From the drop-
down list, select Activator.

NOTE For more information about Avalanche MC, refer to the Wavelink 
Avalanche Mobility Center User’s Guide.

Launching the Activator in Avalanche Manager

If you are installing the Remote Control software package in Avalanche 
Manager, you can launch the activator from the configuration menu of the 
software package.

To launch the activator for Avalanche Manager:

• From the Tree View in Avalanche Manager, right-click the software 
package and select Activator from the menu.
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Activating Remote Control

When you activate Remote Control, a license file called wavelink.lic is 
installed on your system. This file provides the information the product needs 
to operate. There are three methods of activating your Remote Control license:

• Activating Automatically

• Activating Manually

• Importing a License

Activating Automatically

If your Avalanche Manager or Avalanche MC Console resides on a system that 
has Internet access, you can use the automatic license activation. 

When you use the automatic activation method, Avalanche Manager or 
Avalanche MC connect with a secure Wavelink Web site to verify your license 
and nodelock, and a license file is sent to your host system.

The license file called wavelink.lic is installed on your system, which 
provides the information the product needs to operate. 

To activate Remote Control:

1 Obtain the Avalanche MC product licensing code from Wavelink.

NOTE You receive this information in an e-mail from Wavelink upon 
purchasing Wavelink Remote Control. Contact Wavelink Customer Support if 
you have not received this e-mail.

2 Access the Wavelink Activator from the Start menu or from the Remote 
Control Configuration menu.
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Figure 3-1. Wavelink Activator

3 Type your license number for this installation in the Product License text 
box.

4 Click Activate.

Remote Control connects with a secure Wavelink web site, your license and 
nodelock are verified, and a license file is sent to your host system. A new 
dialog box appears, specifying your licensing information and asking if you 
want to save this information for this installation.

5 Click Yes to accept the license file and activate your installation.

Activating Manually

If the server is not connected to the internet or if you have problems with the 
automatic activation, you can activate your license manually. 

To activate your license manually you will need the following information:

• NodeLock for the machine. You can get this information from the 
Activator found in the Start menu.

• Product License. You can get this information from the e-mail you 
received from Wavelink upon purchasing Avalanche MC.
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• e-mail Address. You need a valid e-mail address. This is where the license 
file will be sent.

To activate Remote Control:

1 Gather the information needed to license.

2 Open a web browser and navigate to http://www.wavelink.com/
activation.

3 Enter the Hardware Node Lock and the License in the text boxes.

4 Select which Wavelink Product you are activating.

5 Enter your registration information in the Registration region. (This step is 
optional.)

6 Enter a valid e-mail address.

7 Click Activate License. 

When you click Activate License, the Wavelink activation server 
verifies the information you entered and then e-mails the wavelink.lic 
file to the e-mail address you entered. 

8 Check your e-mail to ensure you received the wavelink.lic file and 
then follow the steps to import a license file.

Importing a License

If you already have a license file for Avalanche MC or you have received the 
wavelink.lic file using the manual activation method, you can activate 
the license by importing it into the Activator.

You have the option of importing multiple license files or consolidating 
several files.

To import a license:

1 Access the Wavelink Activator from the Start menu or from the Remote 
Control Configuration menu.
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Figure 3-2. Wavelink Activation 

2 Click Browse and navigate to the location of the wavelink.lic file.

3 Select the wavelink.lic file and click Yes.

4 In the Wavelink Activation dialog box, click Close.

Activating Demo Mode

If you are installing Remote Control for demonstration purposes, you can run 
the product in demo mode. Demo mode gives you full Remote Control 
functionality on two mobile devices for 30 days.

To activate demo mode:

1 Access the Wavelink Activator from the Start menu or from the default 
Remote Control Configuration menu.

The Wavelink Activation dialog box appears.
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Figure 3-3. Wavelink Activation

2 Click Demo.

Remote Control will run in demo mode for up to 30 days.

 Changing the License Server

You change the License Server and port number from the Licenses tab of the 
Remote Control Console. For details about launching the Remote Control 
Console, refer to Chapter 4: Launching the Wavelink Remote Control Console on 
page 31.

To change the License Server:

1 Launch the Remote Control Console and select the Licensing tab.

2 In the License Server text box, enter the name of the License Server you 
want to use.

3 In the Port text box, enter the port number you want the License Server to 
run on.

4 Click Save to save your changes.
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Verifying Licenses

From the Licenses tab of the Remote Control Console, you can verify that the 
License Server is running. You can also compare the total number of Remote 
Control licenses with the number of licenses available.

To verify licenses:

1 Launch the Remote Control Console and select the Licensing tab.

2 In the Verify Connection region, click Verify.

Figure 3-4. Verifying Connections

If the License Server can be contacted, the Status field displays the 
message “Server OK”.

If the License Server can not be contacted, the Status field displays the 
message “Could not verify server”.
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In the Licenses region, you can view your total number of licenses in use 
compared to your total available licenses.
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Chapter 4: Launching the Wavelink Remote 
Control Console

The Remote Control Console provides configuration methods and 
functionality options to customize the way you connect to your mobile 
devices and use the Remote Control product. You can access the Remote 
Control Console through Avalanche Manager or Avalanche MC. The console 
is the same whether you launch it through Avalanche Manager or Avalanche 
MC.

NOTE If you do not have a license for Remote Control, you will have access to 
the Remote Control Console. However, you will be unable to connect to a 
mobile device.

This chapter provides information about launching the Remote Control 
Console including:

• Launching from Avalanche Manager

• Launching from Avalanche MC

Launching from Avalanche Manager

You can launch the Remote Control Console from the Tree View of the 
Avalanche Manager.

To launch the configuration window:

1 In the Tree View of Avalanche Manager, navigate to the software collection 
in which you installed Wavelink Remote Control.

2 Right-click on the WLRMCTL package.

3 Select Configure Package > Remote Control Console.

The Wavelink Remote Control console opens. 
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Figure 4-1. Wavelink Remote Control Console

Launching from Avalanche MC

If you are using Avalanche MC, you can launch the Remote Control Console 
from the Software Collections tab or from the Mobile Device Inventory tab.

To launch from the Software Collections tab:

1 Right-click the Remote Control package in the Software Collections tab 
and select Configure.
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Figure 4-2. Configure Remote Control

The Configure Software dialog box appears.

2 From the drop-down menu, select Remote Control Console.

To launch from the Mobile Device Inventory tab:

1 Double-click the mobile device to which you want to connect Remote 
Control.

The Mobile Device Details dialog box appears.

2 Click the Device Controls tab.

Figure 4-3. Communication Set Icon
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3 Double-click the Communication Set icon.

The Remote Control Console launches in a separate window.
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Chapter 5: Creating Remote Control 
Connection Profiles

Remote Control allows you to configure connection profiles to use to connect 
to your mobile device. Connection profiles are a collection of connection 
settings. You can apply profiles to devices depending on what type of 
connection you want to make with the device. 

When you create profiles, you select one profile to use as a default profile. The 
default profile will be used for connections when you do not specify a specific 
profile for a mobile device.

Configuring profile settings consists of the following tasks:

• Configuring the Connection Settings

• Configuring the Remote Display

• Configuring Logging

• Configuring the Capture and Record Methods

Each of these tasks is performed from the Profiles tab of the Remote Control 
Console. For information about launching the Remote Control Console, refer 
to Chapter 4: Launching the Wavelink Remote Control Console on page 31.

Configuring the Connection Settings

You can create and configure new connections for Wavelink Remote Control 
based on the type of connection between the mobile device and the PC.

Remote Control supports the following communication methods (listed from 
slowest to fastest):

• Serial over ActiveSync

• LAN over ActiveSync

• LAN or WAN direct

When you use the LAN communication method, the Remote Control will 
broadcast a short message on the network once every second to find the CE 
server side without having to know the server IP address in advance. All of 
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the devices that respond will be displayed in the Connections list. Once a 
connection is made no more broadcast messages will be sent. This method 
will not be able to get past routers, but is convenient when using dynamic IP 
addresses.

The WAN setting will use the provided IP address to connect to the target CE 
machine even across the internet (not through firewalls). To get through 
firewalls, allow ports 1899 and 1903 to operate.

When using a direct communication method, ensure ActiveSync is not using 
the same communication method. Uncheck the settings in the ActiveSync 
Configuration dialog for serial or USB connections.

It is preferable to use a direct communication method, if possible.

To configure the connection settings:

1 In the Profiles tab of the Remote Control Console, enter a name for the 
profile you are creating in the Name text box.
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Figure 5-1. Configuring the Connection Settings

2 From the Connection Type drop-down list, select the connection method 
by which you want to connect to a mobile device.

3 In the Timeout text box, enter the number of seconds you want to elapse 
before the Remote Control stops attempting to connect and times out. 

4 If you want to use this profile as the default profile that will be applied to 
all device connections, enable the Use as Default option.

NOTE There can only be one profile set as the default profile at a given time. 
The default profile will be applied to every Remote Control connection that 
does not specifically state which profile to use. 
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5 Enable the Queue events option to send groups of requests to the mobile 
device rather than sending each request as a single package.

6 If you want to force the device screen to display in grayscale, enable the 
Force grayscale on pallet device(s) option.

NOTE This option only applies to devices that have a video controller using a 
8 bit per pixel pallet display. This option does not affect any device using 
more than 256 colors.

7 Click Update to update the profile with the configuration changes or 
continue configuring the profile.

Configuring the Remote Display

Remote Control allows you to configure the way you want the remote device 
to display in the Remote Control connection window. You can configure how 
large the image is, how often you want to refresh the screen and whether to 
show a skin of the device to which you are connected.

To configure the Display/Skin:

1 In the Profiles tab of the Remote Control Console, select the profile you are 
configuring from the profile list.

2 From the drop-down list in the Display/Skin region, select the Refresh 
Rate.

The refresh rate can range from 1 to 18 frames per second. Your selection is 
dependent on the speed of the mobile device and the communication 
method you are using. Select the best setting for your usage that does not 
impact the mobile device CPU too heavily and allows for reasonable 
screen updates.

3 From the drop-down list in the Display/Skin region, select the Scale.

You can magnify the screen display from .5X-4X.

4 If you want to allow a selected skin to display, enable the Show Skin 
option.
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5 From the drop-down list in the Display/Skin region, select the Skin you 
want to display.

If you want Remote Control to auto-detect which skin to display, select the 
AutoDetect option. For more information about skins, refer to Chapter 
10: Using Skins on page 111 and Chapter 11: Using the Keymap Editor on 
page 115

6 Click Update to update this profile with the configuration changes or 
continue configuring the profile.

Configuring Logging

Logging allows you to track the connections and actions of Remote Control. 
For more information about viewing this log file, refer to  Accessing the Log 
File on page 72.

Logging levels include:

• Critical. Indicates errors that cause Remote Control to fail to start.

• Errors. Indicates errors that are caused by configuration and/or 
communication problems.

• Warning. Indicates possible operational problems.

• Info. Documents the flow of operation.

• Debug. Used to diagnose program malfunctions or communication 
problems.

• None. No information is logged.

To configure logging:

1 In the Profiles tab of the Remote Control Console, select the profile from 
the profile list that you are configuring.

2 From the Level drop-down list in the Logging region, select the level at 
which you want to log information.

3 Enter the maximum size the log file should reach before creating a new log 
file in the Max Size text box.
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4 Click Update to update this profile with the configuration changes or 
continue configuring the profile.

Configuring the Capture and Record Methods

You can capture screen shots using three different methods:

• File. Use this option to save the image to a specified file.

• Clipboard. Use this option to place the image on the clipboard.

• One-click. Use this option to click once and send the screen capture to a 
previously specified file format. The file format must be chosen in the 
either the Default Settings dialog box or the New Connection dialog box. The 
file name will be automatically created based on the current time and date. 
The file will be placed in the default 
C\:_AVA\localhost\MAIN\[Device 
Name]\WLRMTCTL\APPS\WLRMTCTL\RECORDED_DATA folder.

Wavelink Remote Control allows you to record AVI files. The AVI file is saved 
in the C:\_AVA\localhost\MAIN\[Device 
Name]\WLRMTCTL\APPS\WLRMTCTL\RECORDED_DATA folder.

The AVI file can then be played on any program compatible with the AVI 
video file format, such as Windows Media Player.

To configure capture and recording methods:

1 In the Profiles tab of the Remote Control Console, select the profile from 
the profile list that you are configuring.

2 In the Capture region, select the Screen Capture method based on how 
you want to capture screen images.

3 From the Format drop-down list, select the format in which you want to 
save your screen captures.

4 From the Recording Method region, select the method by which you want 
to record actions.

• Enable the Script option if you want to save your actions as a script file.

• Enable the AVI option if you want to save your actions as an AVI 
recording.
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5 Enable the Display Mouse option if you want to display the mouse in the 
AVI file or script.

6 Click Update to update this profile with the configuration changes.

The profile is now complete. You can create as many connection profiles as 
you need.
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Chapter 6: Configuring Client-Side Settings
From the Client Config. tab you can configure connection type, connection 
password, and whether to allow configuration changes from the mobile 
device. These settings are downloaded to the mobile device when the 
package is downloaded.

You have the option of configuring the client-side settings from the Remote 
Control Console. Or if you have configured the Remote Control application to 
be configured from the mobile device, you can also configure the settings 
there. 

Client-Side Settings from the Console

You can configure the following client settings:

• Connection Type. Use this option to select the connection method by 
which Remote Control can be connected to the mobile device.

• Password. When you set a password in this text box, Remote Control users 
will be required to input a password before they can connect to that 
mobile device.

• Require for LAN. Enable this option to require that a password be entered 
before connection to the mobile device will be allowed over the LAN.

• Sleep While Connected. When this option is enabled, the mobile device is 
allowed to revert to sleep-mode while connected to Remote Control.

• Disable Client Exit. When this option is enabled, the mobile device user is 
prohibited from exiting the Remote Control application.

• Notify User on Connection. Use this option to notify the mobile device 
user when a Remote Control connection is established with the user’s 
mobile device.

• Allow Client Config. When this option is enabled, the mobile device user 
is allowed to configure the Remote Control client from the mobile device. 
If this option is enabled and then the client settings are deployed to the 
mobile device, any changes made in the Client Config tab from the Remote 
Control Console will not be deployed to the device. To regain Client 
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Configuration setting control from the Remote Control Console, you will 
need to disable this option and redeploy the settings to the mobile device.

• Seconds. You can set the number of seconds you want the Remote Control 
Connected/Disconnected screen displays on the mobile device.

Once you configure the client settings from the Remote Control console, those 
settings are deployed to the mobile device. 

To configure client settings from the console:

1 Launch the Remote Control Console.

2 Click the Client Config. tab.
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Figure 6-1. Client Config. Tab

3 From the Connection Type drop-down menu, select the connection 
method.

4 Enter a Password if you want to require a password before connecting to a 
mobile device.

5 Enable the Require for LAN option if you want to require the user to input 
a password before connecting to a device over a LAN connection.

6 If you want to allow the mobile device to sleep while connected to 
Wavelink Remote Control, enable the Sleep While Connected option.
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7 If you want to allow the mobile device to configure these settings, enable 
the Allow Client Config option.

NOTE If the Allow Client Config option is enabled and then the client 
settings are deployed to the mobile device, any changes made in the Client 
Config. tab from the Remote Control Console will not be deployed to the 
device. The mobile device will have control of the client configuration 
settings. To regain client configuration setting control from the Remote 
Control Console, you will need to disable this option and redeploy the 
settings to the mobile device. You can also use the Clear Client 
Settings option.

8 If you want to prohibit the mobile device from exiting Wavelink Remote 
Control, enable the Disable Client Exit.

9 If you want Remote Control to notify the mobile device user when a 
Remote Control connection is established with that mobile device, enable 
the Notify User On Connect option.

10 In the Seconds text box, enter the number of seconds you want the Remote 
Control Connected/Disconnected screen displays on the mobile device.

11 Click OK.

The settings are deployed to the mobile device.

Configuring Client Information from the Mobile Device

Before you can configure client settings from the mobile device, you must 
enable the Allow Client Config option in the Client Config tab on the Remote 
Control Console. This allows the mobile device user to configure passwords, 
connection types and other client-side configuration options from the mobile 
device.

For more information about enabling the Allow Client Config option, refer 
to  Client-Side Settings from the Console on page 41.

If you disable the Allow Client Config option, the mobile device user will not 
be allowed to access the client information on the mobile device. 
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To configure client information from the mobile device:

1 Launch the Remote Control application on the mobile device.

2 From the File menu, click Configure.

The Configure dialog box opens (Figure 6-2).

Figure 6-2. Configuring Client Settings

If the Allow Client Config option is not enabled, the Not Available dialog 
box will appear, instead. 

3 From the drop-down menu, select your connection type.

4 If you want to require a password before allowing a Remote Control 
session, enter a Password.

5 Enable the Require a password for LAN option.

6 Click OK.

The Remote Control application is updated with the new client settings.

Clearing Client Settings

You can clear all client configuration settings using the Clear Client 
Settings option in Remote Control connection window. When you select 
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this option, all your client configurations are removed, including anything 
that was configured on the mobile device. This option is useful if you have set 
the Allow Client Config option and no longer have access to modify the client 
settings from the Remote Control Console.

To clear client settings:

• From the Tools menu in the Remote Control connection window, select 
Clear Client Settings.
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Chapter 7: Connecting to the Mobile 
Device

Once you have configured profiles in the Wavelink Remote Control console 
and downloaded the Remote Control package to the mobile device, you can 
create Remote Control connection sessions.

This section provides information about the following Remote Control 
connection tasks:

• Creating a Remote Control Session 

• Automatically Discovering Mobile Devices

• Closing a Remote Control Connection Session

NOTE If you have not licensed Remote Control, you will not be able to connect 
to the mobile device.

Creating a Remote Control Session

You can create a Remote Control connection session over an ActiveSync or 
TCP/IP connection. If you are creating a session using ActiveSync, ensure you 
have created an ActiveSync session. If you are creating a session using a TCP/
IP connection, ensure you know the IP address of the mobile device.

To create a Wavelink Remote Control session:

1 Launch the Remote Control Console.

For detailed information about launching the Remote Control Console, 
refer to Chapter 4: Launching the Wavelink Remote Control Console on page 31.

2 From the Remote Control Console, select the Mobile Devices tab.

3 From the Mobile Device list, select the mobile device to which you want to 
connect.
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Figure 7-1. Selecting a Connection

4 In the Profile list box, select the profile you want to use to connect to this 
device.

5 If you use the default tcpip profile, enter an IP address for the mobile 
device in the IP address text box.

6 If you want to test your connection, click Test Connect.

Remote Control attempts a test connection to the mobile device.

7 Use one of the following methods to connect to the mobile device:

• From the File menu in the Mobile Device tab, select Connect.
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-or-

• From the Mobile Device tab, select the mobile device name and click 
Connect.

8 If the device requires a password, the Password Required dialog box 
appears.

9 Enter the Password and click OK.

The Wavelink Remote Control connection window appears.

Figure 7-2. Wavelink Remote Control Connection Window

Clicking within the Wavelink Remote Control connection window will 
send the mouse click to the connected device. Typing on the physical 
keyboard will send the key commands to the mobile device.
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Automatically Discovering Mobile Devices

If you are working with devices on a LAN, Remote Control can auto-discover 
which devices are in listening range. Once you have discovered the devices 
on your LAN, you can connect to these devices. Remote Control can also be 
configured to allow discovery across subnets and update the Remote Control 
database with the results.

Each device can optionally be configured with a password to protect it from 
unauthorized access. The password is configured in the Client Configuration 
dialog box. For more information on configuring the password, refer to 
Chapter 6: Configuring Client-Side Settings on page 41. Once the password is 
confirmed, Remote Control connects with the device.

Adding Networks

To allow discovery across subnets, you can add networks to the Search 
Networks regions in the Autodiscovery tab.

You can add new networks to the Search Networks region. When you add a 
network to the Search Networks region, you set the first three octets of the 
network address. Then Remote Control sends requests to addresses 
xxx.xxx.xxx.0 through xxx.xxx.xxx.254 attempting to contact mobile devices 
at each of those addresses.

Once you add a network, that network is immediately considered the current 
search network. This means when you begin a device search by clicking the 
Start button, Remote Control is searching for devices within that network. 

If you want to search for devices in a different network, you can click any 
network address in the Search Networks region. If Remote Control is 
performing a device search, then the network you select will be searched 
immediately. If Remote Control is not performing a device search, you can 
click the Start button to begin the search of that network. 

You can use the Delete button to delete networks you have added to the 
Search Networks.

To add a network: 

1 From the Remote Control Console, click the Auto Discovery tab.

2 In the Search Networks region, click Add.

The Add Network dialog box appears.
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Figure 7-3. Add Network

3 Enter the first three octets of the network address.

4 Click OK.

The address is added to the Search Networks region and becomes the 
current search network. If a search is in progress, Remote Control will 
automatically search for mobile devices within that network. If you have 
not started a search, click the Start button to begin looking for mobile 
devices within that network.

Removing Networks

If you no longer need to search a network, you can remove it from the Search 
Networks region.

To remove a network address:

1 From the Remote Control Console, click the Auto Discovery tab.

2 In the Search Networks region, select the network address you want to 
remove and click Delete.

A Remote Control dialog box appears.

Figure 7-4. Remote Control

3 Click Yes to confirm that you want to delete the network.
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The network is removed from the Search Networks region.

Configuring the Auto Discovery Settings

Remote Control discovery parameters allow you to customize the manner in 
which Remote Control auto discovers devices. You can configure the auto 
discover settings in the Autodiscovery Settings dialog box. This dialog box 
allows you to configure the following:

• Enable. This option allows you to enable or disable the Local UDP 
broadcast method of auto-discovery. This option is enabled by default. 

• Broadcast Interval. This option allows you to set how often broadcasts are 
sent. 

• Use Fast Search. This option skips querying each device on the network. It 
sends out the discovery request to xxx.xxx.xxx.255. This works quickly but 
does not provide 100% complete device detection. This option is not 
enabled by default. When it is not enabled, each device is sent the 
discovery request. This results in a longer discovery time but with more 
accurate results.

• Device wait time. This option determines how long the Remote Control 
console will wait for a device to respond to a request before attempting to 
contact the next device. 

To configure auto-discovery settings:

1 From the Remote Control Console select Settings > Set Discovery 
Parameters.

The Autodiscovery Settings dialog box appears. 
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Figure 7-5. Autodiscovery Settings Dialog Box

2 If you want to use the Local Area Broadcast method, enable the Enable 
option.

3 Enter the number of seconds between each broadcast in the Broadcast 
Interval text box.

4 If you want to perform a fast search, enable the Use Fast Search option.

5 Enter the number of seconds you want the Remote Control Console to wait 
for device responses in the Device wait time text box.

6 Click OK. 

The discovery parameters are saved and the Autodiscovery Settings dialog 
box closes.

Discovering Devices

When working with devices on a LAN, Remote Control will broadcast a 
message based on the discovery parameters you set in the Autodiscovery 
Settings dialog box.

To auto-discover devices:

1 From the Remote Control Console, click the Auto Discovery tab.

2 Click Start.
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Remote Control will broadcast a message over the LAN to discover which 
devices are in listening range. Any devices that you can connect to using a 
LAN connection will appear in the list box. The names that appear are the 
names of the mobile devices.

3 If you want to search for devices in a different network, select the network 
in the Search Networks region.

Because a search is already in progress, Remote Control will immediately 
begin searching the selected network. Any discovered devices will appear 
in the list box.

Connecting to Auto-Discovered Devices

Once you have used the Auto-Discovery feature to locate your mobile 
devices, the devices also appear in the Mobile Device list in the Mobile Device 
tab. From this tab, you can connect to an auto-discovered device. Devices that 
have been discovered automatically appear in the list as Autodiscover - 
X.X.X.X, where X.X.X.X is the IP of the mobile device.

To connect to an auto-discovered device:

1 From the Mobile Device list, select the mobile device to which you want to 
connect. 

2 In the Profile list box, select the profile you want to use to connect to this 
device.

3 If you want to test your connection, click Test Connect.

Remote Control attempts a test connection to the mobile device.

4 Use one of the following methods to connect to the mobile device.

• From the File menu in the Mobile Device tab, select Connect.

-or-

• From the Mobile Device tab, select the mobile device name and click 
Connect.

5 If the device requires a password, the Password Required dialog box 
appears.

6 Enter the Password and click OK.
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The Wavelink Remote Control connection window appears.

Figure 7-6. Wavelink Remote Control Connection Window

Clicking within the Wavelink Remote Control connection window will 
send the mouse click to the connected device. Typing on the physical 
keyboard will send the key commands to the mobile device.

A new menu entry “Settings->Set Discovery Parameters” has been added 
to control how auto-discovery functions.

When the add option is chosen the following dialog is displayed.

When the delete option is selected the following confirmation is displayed.

When auto-discovery has been started, the current network and progress 
is displayed as shown on the following screen.
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When using the fast search option the following version of the screen is 
displayed.

Closing a Remote Control Connection Session

There are two methods to close a Remote Control session. You can close the 
Remote Control connection window or you can force a remote disconnect.

To close the Remote Control connection window:

• From the Remote Control connection window, select File > Exit.

-Or-

• Close the Remote Control connection window.

To force a Remote Control disconnect:

1 Launch the Remote Control Console.

For detailed information about launching the Remote Control Console, 
refer to Chapter 4: Launching the Wavelink Remote Control Console on page 31.

2 From the Remote Control Console, select the Mobile Devices tab.

3 From the Mobile Device list, select the mobile device for which you want 
to close the session.

4 Click Status.

The Device Status dialog box appears. This dialog box provides device and 
connection information. 



Chapter 7: Connecting to the Mobile Device 57

Figure 7-7. Device Status Dialog Box

If the mobile device is still connected to a Remote Control session, the 
Device Status line will display Connected.

5 Click Disconnect.

The mobile device is disconnected from the Remote Control session.
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Chapter 8: Using Wavelink Remote Control
This chapter provides information about using Remote Control once you 
create a connection session to a mobile device. For information about creating 
a connection session, refer to Chapter 7: Connecting to the Mobile Device on 
page 47.

Once you are connected to a mobile device, Remote Control offers a variety of 
functionality, tools and configuration you can use. 

Figure 8-1. Remote Control Connection Window

The Remote Control connection window is made up of the following tabs:

• Device. This allows you to view the mobile device. From this tab you can 
perform any operations on the mobile device using key strokes and mouse 
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actions. You can also perform Remote Control operations such as toggle 
the skin, perform screen captures, and record scripts and AVI files.

• File System. From this tab you can access the file system on the mobile 
device. For detailed information about tasks you can perform in the File 
System tab, refer to  Using the File System on page 57.

• Registry Viewer. The Registry Viewer allows you to view and edit the 
registry on the mobile device. For detailed information about the Registry 
Viewer, refer to  Using Registry Viewer on page 62.

• Processes. The Process Manager allows you to view the processes that are 
currently running on the mobile device. For detailed information, refer to  
Using the Process Manager on page 71.

• Access Log. The Remote Control logging feature stores information about 
the current connection session of Remote Control. For detailed 
information, refer to  Accessing the Log File on page 72.

• Device Info. The Device Info tab provides information about the mobile 
device to which you are connected. For detailed information, refer to  
Viewing Device Info on page 76.

• Scripts. The Scripts tab allows you to run configured script scenarios. For 
more information about scripts and scenarios, refer to Chapter 9: 
Configuring Scripts and Scenarios on page 95.

This chapter also provides information about the following tasks:

• Performing Screen Captures

• Configuring Skins

• Using the Paste Feature

• Recording an AVI File

Viewing the Mobile Device

When you create a Remote Control connection session, the Remote Control 
connection window displays the Device tab by default. This tab allows you to 
see the mobile device screen. Clicking within the Wavelink Remote Control 
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connection window will send the mouse click to the connected device. Typing 
on the physical keyboard will send the key commands to the mobile device.

Using the File System

You can access the File Explorer of the mobile device from your PC server. 
This allows you to perform tasks and operation in the File Explorer on the 
mobile device from your Remote Control connection session.

This section provides information about following tasks you can perform in 
the File Explorer:

• Opening the File Explorer

• Creating New Folders

• Copying Files to the PC

• Copying Files from the PC to the Mobile Device

• Opening Files

• Deleting Files

• Deleting Files

Opening the File Explorer

You can use the File Explorer to create new folders, rename folders, delete 
folders and move files from the mobile device to the PC.

To open the File Explorer:

1 Establish a Remote Control connection session.

2 When the Remote Control connection window opens, click the File System 
tab.

The WL Remote Control File Explorer opens. 
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Figure 8-2. File System Explorer

NOTE If you are using Avalanche MC, you can also access the File System 
Mobile Device Details dialog box. Click the Device Control tab and then 
double-click the File System icon.

Creating New Folders

You can create and name folders in the File Explorer. 

To create a new folder:

1 Open the File Explorer.

2 Navigate to the location where you want to create the new folder.

3 Right-click and select New.
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The folder is created in the selected location.

4 Right-click the new folder and select Rename Folder. 

5 Type the name of the folder.

Copying Files to the PC

You can select files on the device to copy to the PC or you can select files on 
the PC to copy to the device.

To copy files to the PC:

1 In the Remote Control connection window, open the File Explorer.

2 Select the file you want to copy to the PC.

3 From the View menu, select Copy to PC.

-Or-

Right-click the file you want to copy and select Copy to PC.

The Browse for Folder dialog box opens. 

4 Navigate to the location where you want to save the file.

5 Click OK.

The folder will be copied to the selected location.

Copying Files from the PC to the Mobile Device

You also have the option of copying files from the machine running Remote 
Control and placing them in the File Explorer on the mobile device to which 
you are connected.

To copy files to the PC:

1 In the Remote Control connection window, open the File Explorer.

2 Using the Tree View, navigate to the location where you want to save the 
file on the mobile device

3 From the View menu, select Copy from Remote.

The Open dialog box appears. 
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4 Locate the file that you want to copy to the mobile device and click OK.

The Sending Files Status dialog box appears.

Figure 8-3. Sending Files

The file will be copied to the selected location.

5 Once the file transfer is complete, click OK.

Running Programs

From the File Explorer, you can run programs located on the mobile device. 
You can run any file with an .exe extension. To open other types of files, 
refer to  Opening Files on page 61.

To run a program:

1 In the Remote Control connection window, open the File Explorer.

2 Using the Tree View, navigate to the location of the program you want to 
run.

3 Select the program and from the Files menu, select Run.
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-Or-

Right-click the file and select Run.

The program will run and open on the mobile device. 

4 Click the Device tab to view the mobile device screen and the program.

Opening Files

You access files on the mobile device by opening them from the File Explorer. 
For .exe files, refer to  Running Programs on page 60.

To open a file:

1 In the Remote Control connection window, open the File Explorer.

2 Using the Tree View, navigate to the location of the file you want to open.

3 Select the file and from the Files menu, select Open.

-Or-

Right-click the file and select Open.

The file will open and display on the mobile device. 

4 Click the Device tab to view the mobile device screen and the file.

Deleting Files

You can delete files on the mobile device from the File Explorer.

To delete files:

1 In the Remote Control connection window, open the File Explorer.

2 Navigate to the location of the file you want to delete.

3 Select the file and from the Files menu, select Delete.

-Or-

Right-click the file and select Delete.

The file is removed from the File Explorer.
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Using Registry Viewer

The Registry Explorer allows you to browse and view the Registry of the 
mobile device from the Remote Control connection window.

This section provides information about the following Registry Viewer tasks:

• Viewing the Registry

• Creating New Registry Keys

• Creating Key Values

• Viewing Binary Data

• Modifying Key Values

• Modifying Binary Data

• Deleting Key Values

• Exporting Registries

• Comparing Registries

Viewing the Registry

You can view the registry from the Remote Control connection window.

To view the registry of the device:

1 Establish a Remote Control connection session.

2 When the Remote Control connection window opens, click the File System 
tab.

The WL Remote Control Registry Viewer appears. 
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Figure 8-4. Viewing the Registry Viewer

3 Expand the registry by clicking on a menu item that appears in the registry 
viewer.

NOTE If you are using Avalanche MC, you can also access the File System 
Mobile Device Details dialog box. Click the Device Control tab and then 
double-click the Registry Viewer icon.

Creating New Registry Keys

From the Registry Viewer tab, you have the ability to create new registry keys 
on the mobile device.

To create a new registry key:

1 In the Remote Control connection window, open the Registry Viewer.
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2 Using the Tree Menu, navigate to the where location you want to create a 
new key.

3 Right-click and select New Key.

A New Key folder appears.

4 Right-click the New Key folder and select Rename.

5 Name the folder.

Creating Key Values

You also have the ability to create key values in the mobile device registry. 
You can create String, Binary, DWORD, and Multi-String values.

To create key values:

1 In the Remote Control connection window, open the Registry Viewer.

2 Using the Tree Menu, navigate to the location where you want to create a 
new key.

3 Right-click and from the menu that appears, select the key value you want 
create.

The value appears in the file list box.

Viewing Binary Data

For any registry key, you can display the binary data for that key.

To view binary data:

1 In the Remote Control connection window, open the Registry Viewer.

2 Using the Tree Menu, navigate to the location of the key you want to view.

3 Right-click the key and select Display Binary Data.

The Binary Data dialog box appears.
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Figure 8-5. Binary Data 

4 Use the options in the Format region to display the data in Byte, Word or 
Dword format.

5 Click OK when you are finished.

Modifying Key Values

You have the ability to modify key values in the Registry Viewer.

To modify key values:

1 In the Remote Control connection window, open the Registry Viewer.

2 Using the Tree Menu, navigate to the location of the key you want to edit.

3 Right-click the key and select Modify.

A dialog box appears according to what type of key you are modifying.

• If you are modifying a String or Binary value, the Edit String dialog box 
appears.
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Figure 8-6. Edit String

• If you are modifying a DWORD key value, the Edit DWORD Value dialog 
box appears.

Figure 8-7. Edit DWORD Value

• If you are modifying a Multi-String value, the Edit Multi-String dialog box 
appears.
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Figure 8-8. Edit Multi-String

4 Using the configuration options available in each dialog box, edit the key 
value.

5 Click OK when you are finished.

The key value is modified.

Modifying Binary Data

You have the ability to modify the binary data of each type of key value in the 
Registry Viewer.

To modify binary data:

1 In the Remote Control connection window, open the Registry Viewer.

2 Using the Tree Menu, navigate to the location of the key you want to 
modify.

3 Right-click the key and select Modify Binary Data.

The Edit Binary Value dialog box appears.
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Figure 8-9. Edit Binary Value

4 In the Value data text box, edit the binary value as desired.

5 Click OK when you are finished.

Deleting Key Values

You can delete key values that you no longer need.

To delete key values:

1 In the Remote Control connection window, open the Registry Viewer.

2 Using the Tree Menu, navigate to the location of the key you want to 
delete.

3 Right-click the key and select Delete.

A dialog box appears asking you to confirm that you want to delete this 
key value.

4 Click Yes if you want to permanently want to delete the value.

The key value is removed from the registry.
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Exporting Registries

You can export registries from the mobile device and save them as .xml files 
on your PC. 

The default location for exported registries is: 
C:\_AVA\localhost\MAIN\RC\WLRMTCTL\APPS\WLRMTCTL\DeviceRe
gistry

To export a registry:

1 In the Remote Control connection window, open the Registry Viewer.

2 Using the Tree Menu, navigate to the location of the registry you want to 
export.

3 From the File menu, select Export.

A standard Save As dialog box appears.

4 Navigate to the location where you want to save the registry.

5 Name the registry and click Save.

The registry is saved as an .xml file.

Comparing Registries

There are two methods you can use to compare registries:

• Compare to an Existing Registry

• Compare to Another Device Registry

Compare to an Existing Registry

You can compare the registry on a mobile device to a registry you have saved 
and exported. 

To compare to an existing registry:

1 In the Remote Control connection window, open the Registry Viewer.

2 From the File menu, select Compare.

A dialog box appears.
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Figure 8-10. Compare To

3 Select the Existing Registry option and click OK.

A standard Open dialog box appears.

4 Navigate to the location of the registry to which you want to compare and 
click Open.

A Registry Compare dialog box appears in a separate window displaying 
the existing registry file.

5 Move the windows until you can view both registries.

6 When you are finished comparing registries, you can close the Registry 
Compare dialog box.

NOTE You can not edit any registry folders or values in the Registry Compare 
dialog box.

Compare to Another Device Registry

When you want to compare your device registry to another device’s registry, 
you can connect to the device and open both registries.

To compare to another device registry:

1 In the Remote Control connection window, open the Registry Viewer.

2 From the File menu, select Compare.

A dialog box appears.
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Figure 8-11. Compare To

3 Select the Another Device option and click OK.

The Choose Connection dialog box appears.

4 Select what type of connection you want to create to the new device.

5 If you select to a Network connection, enter the IP address and Port 
number of the mobile device.

A Registry Compare dialog box appears in a separate window displaying 
the mobile device registry file.

6 Move the windows until you can view both registries.

7 When you are finished comparing registries, you can close the Registry 
Compare dialog box.

Using the Process Manager

The Processes tab in the Remote Control connection window allows you to 
view the processes that are currently running on the mobile device. You have 
the option to activate or end (kill) any of the processes. Activating a process 
brings that process to the front of any other programs running on the mobile 
device. Killing a process stops the process.

To use the Process Manager:

1 From the Remote Control connection window, click the Processes tab.
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Figure 8-12. Process Manager

2 Select a Process and right-click to Activate or Kill that process.

Accessing the Log File

The Remote Control logging feature stores information about the current 
connection session of Remote Control. 

This section provides information about the following logging options:

• Configuring Logging

• Viewing the Log File
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• Clearing the Log File

• Saving the Log File

Viewing the Log File

You can view the log file for a current Remote Control session from the 
Access Log tab. 

To view the log file:

• In the Remote Control connection window, select the Access Log tab.

Configuring Logging

Remote Control supports the following log levels:

• Critical. This level writes the least information to the log file, reporting 
only critical errors that have caused the Avalanche Agent service to crash. 

• Error. This level writes Error messages and Critical messages to the log 
file. 

• Warning. This level writes Critical messages, Error messages, and 
Warning messages to the log file. 

• Info. This level is the default logging level and the Wavelink-
recommended setting. This logging level writes enough information to the 
log file to diagnose most problems. 

• Debug. This logging level writes large amounts of information to the log 
file that can be used to diagnose more serious problems. 

You can change the logging for a particular connection session through the 
Configure dialog box located in the Remote Control connection window.

NOTE You can also set up the logging configuration when you create a 
connection profile. For more information, refer to Chapter 5: Creating Remote 
Control Connection Profiles on page 35.

To change the logging configuration:

1 In the Remote Control connection window, select the Access Log tab.
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2 From the File menu, select Configure.

The Configure dialog box appears.

Figure 8-13. Configuring Logging

3 In the Logging region, select the log level from the Level drop-down 
menu.

4 Enter the maximum size you want the log level to reach in the Max Size 
text box.

5 Click OK.

The Configuration Data Change dialog box appears. This dialog box 
indicates that you can changed something from original profile 
configuration.
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Figure 8-14. Configuration Data Changed

6 If you want to use your updated changes, but do not want to update the 
configuration file, select the Use New Configuration option.

7 If want to use your updated changes and would like to update the 
configuration file to reflect those changes, select the Use New 
Configuration and Update config file option.

8 Click OK.

The new logging information is applied.

Clearing the Log File

If you need to delete the information that displays in the log file, you can clear 
the entire file. When you select to clear the log file, the entire log in the Access 
Log tab is removed. You can not select individual items to clear.

To clear the log file:

1 Select the Access Log tab.

2 From the Edit menu, select Clear.

-Or-

Right-click within the log and select Clear.

The Access Log tab is cleared. 

Saving the Log File

The log file does not have a maximum capacity and continues to log 
information until the Wavelink Remote Control console is started again. Once 
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the console is started, the previous log file is reset and information about the 
new connection is stored. However, you can save log files under a different 
name if you wish to retain log files. 

Remote Control log files are stored in the DeviceLogs folder under the 
Remote Control install directory.

To save the log file:

1 Access the Wavelink RemoteControl.log.

2 Open the log file in a plain text editor.

3 Rename the log file as something other than RemoteControl.log.

NOTE If you do not rename the log file and save it, once you restart the 
Wavelink Remote Control console, the previous log will be discarded and the 
RemoteControl.log file will log data from the new connection sessions.

Viewing Device Info

The Device Info tab in the Remote Control connection window provides 
information about the mobile device to which you are connected. This 
information includes:

• Identification, including OEM information and the operating system 
versions.

• Memory, including the amount of free memory left on the device and 
storage space.

• Power, including information about the battery level and charging status 
of the mobile device.

• Screen, including information about the screen size and orientation.

• Security, including password information.

To view device info:

• From the Remote Control connection window, select the Device Info tab.
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Figure 8-15. Device Info

Recording an AVI File

Wavelink Remote Control allows you to record AVI files. The AVI file is saved 
in the RECORDED_DATA folder under the Remote Control install directory.

The AVI file can then be played on any program compatible with the AVI 
video file format, such as Windows Media Player.

This section provides information about the following tasks:

• Selecting the Recording Method

• Recording the AVI File
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Selecting the Recording Method

Before you can record your AVI file, you must enable AVI as the recording 
method. You can select to the AVI recording method from the Configure dialog 
box in the Wavelink Remote Control connection window.

You can change the recording method configuration for a particular 
connection session through the Configure dialog box. 

NOTE You can also configure the recording method when you create a 
connection profile. For more information, refer to Chapter 5: Creating Remote 
Control Connection Profiles on page 35.

To select the recording method:

1 From the File menu in the Remote Control connection window, select 
Configure.

The Configure dialog box appears.
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Figure 8-16. Configuring the Recording Method

2 In the Recording Method region, select the AVI video option as the 
recording method.

3 If you want the cursor to display in the AVI video, enable the Show Cursor 
option.

4 Click OK.

The Configuration Data Change dialog box appears. This dialog box 
indicates that you can changed something from original profile 
configuration.
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Figure 8-17. Configuration Data Changed

5 If you want to use your updated changes, but do not want to update the 
configuration file, select the Use New Configuration option.

6 If want to use your updated changes and would like to update the 
configuration file to reflect those changes, select the Use New 
Configuration and Update config file option.

7 Click OK.

The new recording method information is applied.

Recording the AVI File

You can record actions and tasks and then save your actions as AVI file from 
the Remote Control connection window. These recordings can then be used 
later for demonstration purposes or training. 

To record the AVI file:

1 In the Remote Control connection window, click the Record tool bar icon.

The Save As dialog box appears.
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Figure 8-18. Saving the AVI File

2 Name the file and click Save.

The Video Compression dialog box opens (Figure 8-19).

Figure 8-19. Configuring Video Compression

3 Configure the compression options and click OK.

4 From the Device tab in the Remote Control connection window, perform 
the actions on the mobile device that you want to record.

5 Click the Stop Record tool bar icon when you are finished.
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The AVI file is saved in the \RECORDED_DATA folder in the Remote 
Control installation directory.

Performing Screen Captures

When you are connected to a mobile device through a Remote Control 
session, you can capture screen images from the mobile device. This section 
provides information on the following tasks: 

• Selecting the Screen Capture Method

• Performing Screen Captures

Selecting the Screen Capture Method

Before you can take screen captures using Remote Control, you must select 
the method by which you want to capture the screen image.

You can capture screen shots using three different methods:

• File. Use this option to save the image to a specified file. Once you capture 
the screen image, you asked where you want to save the file.

• Clipboard. Use this option to place the image on the clipboard.

• One-click. Use this option to click once and send the screen capture to a 
previously specified file format. The file format must be chosen in the 
Configure dialog box. The file name will be automatically created based on 
the current time and date. The file will be placed in the default 
C\:_AVA\localhost\MAIN\[Device 
Name]\WLRMTCTL\APPS\WLRMTCTL\RECORDED_DATA folder.

You can configure screen capture methods from the Remote Control 
connection window.

NOTE When you create Remote Control connection profiles, you can 
configure the method by which you want to capture screen images. For more 
information, refer to Chapter 5: Creating Remote Control Connection Profiles on 
page 35. 
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To configure the screen capture method:

1 In the Remote Control connection window, select File > Configure.

The Configure dialog box opens.

Figure 8-20. Selecting a Screen Capture Method

2 In the Screen Capture region, select the method you want to use when 
performing screen captures.

3 Click OK.

The Configuration Data Change dialog box appears. This dialog box 
indicates that you can changed something from original profile 
configuration.



84 Wavelink Remote Control User’s Guide

Figure 8-21. Configuration Data Changed

4 If you want to use your updated changes, but do not want to update the 
configuration file, select the Use New Configuration option.

5 If want to use your updated changes and would like to update the 
configuration file to reflect those changes, select the Use New 
Configuration and Update config file option.

6 Click OK.

The screen capture method you configured is now enabled.

Performing Screen Captures

Once you have configured the screen capture method, you can use the camera 
tool bar icon to capture screen images. 

To perform a screen capture:

1 In the Device tab, navigate to the screen view of the mobile device you 
want to capture.

2 Click the Camera tool bar icon.

The image is saved according to the screen capture method you 
configured in the Configure dialog box.

Configuring Skins

From the Wavelink Remote Control connection window, you can toggle 
between a selected skin and the default view (no skin). To use skins, you must 
enable the Show Skin option when you are creating connection profiles or 
from the Configure dialog box in the Remote Control connection window.
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This section provides information about the following tasks:

• Enabling the Show Skin Option

• Toggling the Skin

Enabling the Show Skin Option

If you did not enable the Show Skin option when you created your 
connection profile, you can configure the connection to display skins from the 
Remote Control connection window.

NOTE You can also configure how you want your mobile device skins to 
display when you create connection profiles. For more information, refer to 
Chapter 5: Creating Remote Control Connection Profiles on page 35.

To enable the Show Skin option:

1 From the File menu in Remote Control connection window, select 
Configure.

The Configure dialog box appears.
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Figure 8-22. Enabling the Show Skin Option

2 Enable the Show Skin option.

3 Select which skin to display from the Skin drop-down list.

4 Click OK.

The Configuration Data Change dialog box appears. This dialog box 
indicates that you can changed something from original profile 
configuration.
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Figure 8-23. Configuration Data Changed

5 If you want to use your updated changes, but do not want to update the 
configuration file, select the Use New Configuration option.

6 If want to use your updated changes and would like to update the 
configuration file to reflect those changes, select the Use New 
Configuration and Update config file option.

7 Click OK.

The skin image will appear in the Device tab of the Remote Control 
connection window.

Toggling the Skin

Once the Show Skin option is enabled, you can toggle between the selected 
skin and the default view of Wavelink Remote Control

To toggle the skin:

• Click the Toggle Skin tool bar icon.

-Or- 

Select View > Toggle Skin.

Refreshing the Display

You can configure the rate at which Remote Control refreshes the mobile 
device screen display.

This section provides the following information:
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• Configuring the Refresh Rate

• Refreshing the Mobile Device Display

Configuring the Refresh Rate

The refresh rate can range from 1 to 18 frames per second. Your selection is 
dependent on the speed of the mobile device and the communication method 
you are using. Select the best setting for your usage that does not impact the 
mobile device CPU too heavily and allows for reasonable screen updates.

NOTE You can also configure the refresh rate option when you create 
connection profiles. For more information, refer to Chapter 5: Creating Remote 
Control Connection Profiles on page 35.

To configure the refresh rate:

1 From the File menu in Remote Control connection window, select 
Configure.

The Configure dialog box appears.
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Figure 8-24. Enabling the Show Skin Option

2 From the Refresh Rate drop-down list, select the rate at which you want 
the screen display to refresh.

3 Click OK.

The Configuration Data Change dialog box appears. This dialog box 
indicates that you can changed something from original profile 
configuration.
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Figure 8-25. Configuration Data Changed

4 If you want to use your updated changes, but do not want to update the 
configuration file, select the Use New Configuration option.

5 If want to use your updated changes and would like to update the 
configuration file to reflect those changes, select the Use New 
Configuration and Update config file option.

6 Click OK.

The device will display as a 16-color image in the Device tab.

Refreshing the Mobile Device Display

Once you have configured the refresh rate, you can use the refresh button to 
update the mobile device screen display.

To refresh the display:

• Click the Refresh toolbar icon.

-Or-

• From the View menu, select Refresh Display.

Sizing Mobile Device Display

You can configure the size that the mobile device display will be upon the 
initial connection of the mobile device. You can configure the display to scale 
from .5x - 4x. Once you are connected to mobile device, you have the option 
of changing this setting and magnifying or shrinking the display.

This section provides the following information:
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• Configuring the Scale Setting

• Changing the Display Size

Configuring the Scale Setting

If you did not configure the scale setting when you created your connection 
profile, you can configure it from the Remote Control connection window.

NOTE You can also configure scale setting when you create connection 
profiles. For more information, refer to Chapter 5: Creating Remote Control 
Connection Profiles on page 35.

To set the scale of the display:

1 From the File menu in Remote Control connection window, select 
Configure.

The Configure dialog box appears.
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Figure 8-26. Enabling the Show Skin Option

2 From the Scale drop-down list, select the size of the mobile device display.

3 Click OK.

The Configuration Data Change dialog box appears. This dialog box 
indicates that you can changed something from original profile 
configuration.
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Figure 8-27. Configuration Data Changed

4 If you want to use your updated changes, but do not want to update the 
configuration file, select the Use New Configuration option.

5 If want to use your updated changes and would like to update the 
configuration file to reflect those changes, select the Use New 
Configuration and Update config file option.

6 Click OK.

The device will appear as the size you selected.

Changing the Display Size

You can change the size of the mobile device display while you are connected 
to a mobile device.

To change the scale size:

• From the View Menu, select Scale and then the size you want the 
display to be.

-Or-

• Use the Zoom In and Zoom Out toolbar options to adjust the size of the 
display.

Using the Paste Feature

Remote Control allows you copy and paste information from the PC to the 
mobile device or from the mobile device to the PC. Only textual information 
can be copied and pasted. For example, you could copy text from a text editor 
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on the PC to Pocket Word on the mobile device. Both text editors must be 
open.

Use the Paste to device command to paste information from the PC to the 
mobile device.

To copy and paste information:

1 Open a plain text editor on both PC and the mobile device.

2 From the text editor on your PC, select the text to be copied and pasted.

3 Right-click and select Copy.

4 In the Remote Control connection window select Edit > Paste to 
device.

The information appears in the text editor on the mobile device. 
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Chapter 9: Configuring Scripts and 
Scenarios

This section provides information about creating scripts and building 
scenarios in Remote Control.

In Remote Control, a script is defined as a recording of a particular action. A 
scenario is a compilation of scripts. Using Remote Control, you can create 
scenarios to control your mobile device. You begin by generating text scripts 
from mouse and keyboard events. You can then arrange and compile these 
scripts to create scenarios based on what you want the device to do and the 
order in which to perform the tasks. 

Scenarios allow you to run several scripts in a predefined sequence. Using 
scenarios you can create predefined commands that activate upon connection 
to a mobile device. 

This section provides information about the following tasks:

• Generating Scripts

• Creating Script Scenarios

• Executing Scenarios

Generating Scripts

You can generate scripts from the Remote Control connection window. Before 
you can record the actions you want to be in the script, you need to set the 
recording method to record script events for that connection. 

Configuring the Recording Method

If your profile is not configured to record script events, you can change the 
configuration from the Remote Control connection window.

NOTE You can also configure create a connection profile that is configured to 
record script events. For more information, refer to Chapter 5: Creating Remote 
Control Connection Profiles on page 35.
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To configure the recording method:

1 Create a Remote Control connection session.

2 From the File menu in the Remote Control connection window, select 
Configure.

The Configure dialog box opens.

Figure 9-1. Configuring the Recording Method

3 In the Recording Method region, select Script events.

4 Click OK.

The Configuration Data Change dialog box appears. This dialog box 
indicates that you can changed something from original profile 
configuration.
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Figure 9-2. Configuration Data Changed

5 If you want to use your updated changes, but do not want to update the 
configuration file, select the Use New Configuration option.

6 If want to use your updated changes and would like to update the 
configuration file to reflect those changes, select the Use New 
Configuration and Update config file option.

7 Click OK.

You can now record script events.

Recording Scripts

Once you have configured the profile to record script events, you can begin 
recording scripts. When you record a script, the script is saved as a plain text 
file in a specified location. 

To record a script:

1 Ensure you have a Wavelink Remote Control session connected.

2 Use one of the following methods to begin recording:

• Click the Record toolbar icon.

-or-

• From the Tools menu, select Start Recording.

3 Use the keyboard and mouse to perform the tasks that you want the script 
to contain.

4 Use one of the following methods to stop recording:
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• Click the Stop Record toolbar icon

-or-

• From the Tools menu, select Stop Recording.

The Save Script dialog box appears.

Figure 9-3. Saving the Script File

5 Enter a name for script and click OK.

The script is saved in the Scenarios.xml file in the Remote Control 
installation directory location.

Editing Scripts

You can manually edit a previously recorded script in a plain text editor or an 
.xml editor.

Use the following keywords and parameters when you are editing a script:

MOUSEDOWN, x, y Simulate a left mouse button press and its 
location.

MOUSEUP, x, y Simulate a left mouse button release and its 
location.
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Each command should be on a separate line. Commas between the keywords 
and the parameters are required. Comment lines begin with a semicolon.

To edit a script:

1 Navigate to the location of the saved script and open the script in a plain 
text editor.

2 Enter the desired commands.

3 Save the edited text file.

Examples

The following script is a sample script displays and then dismisses the About 
dialog and then attempt to launch PQView when it is run in the Wavelink 
Remote Control connection window.

MOUSEDOWN,110,181
SLEEP,371
MOUSEUP,110,181
SLEEP,811
MOUSEDOWN,115,228
SLEEP,330
MOUSEUP,115,228

DOUBLECLICK, x, y Simulate a left mouse button double-click and 
its position.

RMOUSEDOWN, x, y Simulate a right mouse button press and it’s 
location.

RMOUSEUP, x, y Simulate a right mouse button release and it’s 
location.

RDOUBLECLICK, x, y Simulate a right mouse button double-click 
and its location.

MOUSEMOVE, x, y Simulate a mouse move and its location.

KEYDOWN, code Simulate a key press with virtual-key code.

KEYUP, code Simulate a key release.

LAUNCH, appname Launch an application on the remote device.

SLEEP, time Insert a delay of n milliseconds.
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SLEEP,2000
LAUNCH,\Windows\Start Menu\PQView.exe

Creating Script Scenarios

You can create script scenarios by arranging one or more scripts in the either 
the Scripts tab in the Remote Control connection window or in the Scenarios 
tab in the Remote Control Console.

Create Scenarios from the Connection Window

This section provides information following tasks used to create scenarios:

• Adding a New Scenario

• Configuring a Scenario

• Adding Scripts

• Removing Scripts

• Deleting Scenarios

Any scripts that you create in the Remote Control connection window will be 
added to the Scenarios tab in the Remote Control Console.

Adding a New Scenario

When you add a new scenario, it appears in the Scenario list box. 

To add a new scenario:

1 From the Remote Control connection window, click the Scripts tab.
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Figure 9-4. Scripts

2 From the Scenarios menu, select Add.

A new Scenario appears in the Scenarios list box.

Configuring a Scenario

Configuring the scenario allows you to set how many times you want the 
scenario to run, the time delay between each scenario loop and what the 
device should do at the end of the scenario.

To configure a scenario:

1 In the Scripts tab of the Remote Control connection window, right-click the 
scenario and select Edit.
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The Edit Scenario dialog box appears.

Figure 9-5. Editing Scenarios

2 Enter the Scenario Name.

3 In the Loop Count text box, enter the number of times you want this 
scenario to run.

4 In the Loop Delay text box, enter the time delay you between each loop of 
the scenario.

5 If you want to suspend the device when the scenario completes, enable the 
Suspend Device When Complete option.

6 If you want to reboot the mobile device when the scenario completes, 
enable the Reset Device When Complete option.

7 If you want to disable video updates, enable the Disable Video Update 
option.

8 Click OK when you are finished.

Adding Scripts 

You must add at least one script to a scenario to run the scenario.
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NOTE Scripts can not be run on their own. They must be part of a scenario. For 
information about creating scripts, refer to  Generating Scripts on page 95.

To add scripts:

1 Select a scenario from the scenario list box.

2 In the script list box, right-click and select Add.

The Edit Script Entry dialog box appears.

Figure 9-6. Edit Script Entry 

3 From the Script File drop-down list, select which script you want to add to 
this scenario.

4 In the Loop Count text box, enter the number of times you want this script 
to run.

5 In the Loop Delay text box, enter the time delay you between each loop of 
the script.

6 Click OK when you are finished.

The script is added to the scenario. 

7 Continue adding scripts until your scenario is complete.

When you are finished, you can run your scenario. For more information 
about running scenarios, refer to  Executing Scenarios on page 109.
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Removing Scripts

If you have a script that you do not want to be part of a scenario, you can 
remove that script, but keep the rest of the scenario intact.

To remove a script:

1 In the Remote Control Console, select the Scenarios tab.

2 Select the Scenario that contains the script you want to remove.

3 In the script list box, select the script you want to remove from the 
scenario.

4 From the Scripts menu, select Delete.

The script will be removed from the scenario. The script will remain 
available for other scenarios unless you remove it from the Manage Saved 
Events dialog box. For more information, refer to  Managing Saved Events 
on page 108.

Deleting Scenarios

When you no longer need a scenario, you can remove that scenario from the 
list box.

To delete a scenario:

1 In the Remote Control Console, select the Scenarios tab.

2 Select the scenario you want to remove.

3 From the Scenarios menu, select Delete.

The scenario is deleted.

Creating Scenarios from the Console

When you create scenarios in the Remote Control console, you perform the 
same tasks as you would if you created the scenarios in the Remote Control 
connection window, including:

• Adding a New Scenario

• Configuring a Scenario

• Adding Scripts
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This section also provides information about the following tasks:

• Removing Scripts

• Deleting Scenarios

Any scripts that you create in the Remote Control Console will be available in 
the Scripts tab of the Remote Control connection window.

Adding a New Scenario

When you add a new scenario, it appears in the scenario list box. 

To add a new scenario:

1 From the Remote Control Console, click the Scenarios tab.

2 Right-click in the scenarios list box and select Add.

Figure 9-7. 

A new Scenario appears in the scenarios list box.

Configuring a Scenario

Configure the scenario allows you to set how many times you want the 
scenario to run, the time delay between each scenario loop and what the 
device should do at the end of the scenario.
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To configure a scenario:

1 Right-click the scenario and select Edit.

The Edit Scenario dialog box appears.

Figure 9-8. Editing Scenarios

2 Enter the Scenario Name.

3 In the Loop Count text box, enter the number of times you want this 
scenario to run.

4 In the Loop Delay text box, enter the time delay you between each loop of 
the scenario.

5 If you want to suspend the device when the scenario completes, enable the 
Suspend Device When Complete option.

6 If you want to reboot the mobile device when the scenario completes, 
enable the Reset Device When Complete option.

7 If you want to disable video updates, enable the Disable Video Update 
option.

8 Click OK when you are finished.
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Adding Scripts 

You must add at least one script to a scenario to run the scenario.

NOTE Scripts can not be run on their own. They must be part of a scenario.

To add scripts:

1 Select a scenario from the scenario list box.

2 In the script list box, right-click and select Add.

The Edit Script Entry dialog box appears.

Figure 9-9. Edit Script Entry 

3 From the Script File drop-down list, select which script you want to add to 
this scenario.

4 In the Loop Count text box, enter the number of times you want this script 
to run.

5 In the Loop Delay text box, enter the time delay you between each loop of 
the script.

6 Click OK when you are finished.

The script is added to the scenario. 

7 Continue adding scripts until your scenario is complete.
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When you are finished, you can run your scenario. For more information 
about running scenarios, refer to  Executing Scenarios on page 109.

Removing Scripts

If you have a script that you do not want to be part of a scenario, you can 
remove that script, but keep the rest of the scenario intact.

To remove a script:

1 In the Remote Control Console, select the Scenarios tab.

2 Select the Scenario that contains the script you want to remove.

3 In the script list box, select the script you want to remove from the 
scenario.

4 From the Scripts menu, select Delete.

The script will be removed from the scenario. The script will remain 
available for other scenarios unless you remove it from the Manage Saved 
Events dialog box. For more information, refer to  Managing Saved Events 
on page 108.

Deleting Scenarios

When you no longer need a scenario, you can remove that scenario from the 
list box.

1 In the Remote Control Console, select the Scenarios tab.

2 Select the scenario you want to remove.

3 From the Scenarios menu, select Delete.

The scenario is deleted.

Managing Saved Events

You can manage your saved scripts from the Manage Saved Events dialog box. 
This dialog box allows you to view all the scripts you have created and then 
delete them if you no longer need them. Once a script is deleted, it is no 
longer saved in the Recorded_Data folder.



Chapter 9: Configuring Scripts and Scenarios 109

To delete scripts:

1 From the Remote Control Console, select the Scenarios tab.

2 From the Scripts menu, select Manage Saved Events.

The Manage Saved Events dialog box appears.

Figure 9-10. Manage Saved Events

3 Select the script that you want to delete and click Delete Selected 
Events.

The select script is removed.

Executing Scenarios

Once you have completed creating your scenarios, you can run the scenario 
from the Scripts tab of the Remote Control connection window.

To run a script:

1 Establish a Remote Control connection session with a mobile device.

2 In the Remote Control connection window, click the Scripts tab.

3 Select the scenario you want to run on the mobile device and click Run.
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In the script list box and the device view, you will see the scenario run 
through each script. When your script is complete, the Status column in 
the script list box will display Complete.
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Chapter 10: Using Skins
Skins are a way to get the look and feel of the actual mobile device on your PC 
screen. The skins included with the Remote Control are defined with an XML 
file named skins.xml in the directory where the Remote Control program 
is run.

You have the ability to create custom skins and keymaps for any of your 
mobile devices. For more information, refer to Chapter 11: Using the Keymap 
Editor on page 115.

This section provides the following information: 

• Applying Skins

• Toggling Skins

Applying Skins

You can apply or change a skin from the Remote Control connection window 
when you are connected to a mobile device.

NOTE You can also configure to apply skins when you create connection 
profiles. For more information, refer to Chapter 5: Creating Remote Control 
Connection Profiles on page 35.

To apply skin:

1 Create a Remote Control connection session.

2 From the File menu in the Remote Control connection window, select 
Configure.

The Configure dialog box opens.
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Figure 10-1. Selecting a Screen Capture Method

3 Enable the Show Skin option.

4 From the Skin drop-down list, select which skin you want to display.

If you select Autodetect, Remote Control will attempt to detect what 
kind of device you are using and apply that skin.

5 Click OK.

The Configuration Data Change dialog box appears. This dialog box 
indicates that you can changed something from original profile 
configuration.
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Figure 10-2. Configuration Data Changed

6 If you want to use your updated changes, but do not want to update the 
configuration file, select the Use New Configuration option.

7 If want to use your updated changes and would like to update the 
configuration file to reflect those changes, select the Use New 
Configuration and Update config file option.

8 Click OK.

The selected skin will display in the Remote Control connection window.

Toggling Skins

Once you have enabled the Show Skin option, your Remote Control 
connection will display the skin for the mobile device to which you are 
connected. However, you can toggle the skin to display or not display from 
the Device tab in the Remote Control connection window.

To toggle skins:

1 Select the Device tab in the Remote Control connection window.

2 From the View menu, select Toggle Skin.

-Or-

• Click the Toggle Skin icon in the Remote Control connection window 
toolbar.
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Chapter 11: Using the Keymap Editor
Remote Control 2.0 includes the added functionality of a Keymap Editor. The 
Keymap Editor allows you to import custom skin images you create for your 
mobile device. You can then configure Remote Control to automatically 
detect what type of device you are connecting to and display the associated 
skin by default.

The Keymap Editor also allows you to create keymaps for the device skins. 
This allows you to specifically customize the way your mobile device buttons 
perform in the Remote Control connection window. 

This chapter provides information about the following tasks:

• Accessing the Keymap Editor

• Downloading Skins

• Editing Skins

• Editing Skins

• Packaging Skins

Accessing the Keymap Editor

The Keymap Editor is available from the Remote Control software package 
and from the Remote Control Console.

Accessing the Key Map Editor from the Software Package

You can access the Keymap Editor from a Remote Control software package 
installed in either Avalanche Manager or Avalanche MC.

To access from Avalanche Manager:

1 In the Tree View of Avalanche Manager, navigate to the software collection 
in which you installed the Remote Control software package.

2 Right-click on the WLRMCTL package.

3 Select Configure Package > KeyMap Editor.

The Keymap Editor appears. 
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To access from Avalanche MC:

1 Right-click the Remote Control package in the Software Collections tab 
and select Configure.

Figure 11-1. Configure Remote Control

The Configure Software dialog box appears.

2 From the drop-down menu, select KeyMap Editor.

The Keymap Editor appears.

Accessing the Keymap Editor from the Remote Control 
Console

You use the same method to access the Keymap Editor from the Remote 
Control Console in both Avalanche MC and Avalanche Manager.

To access the Keymap Editor:

1 Access the Remote Control Console.

For more information about accessing the Remote Control Console, refer 
to Chapter 4: Launching the Wavelink Remote Control Console on page 31.

2 From the File menu, select Keymap Editor.

The Keymap Editor appears.

Downloading Skins

To reduce the package size, Remote Control is only packaged with a select 
number of device skins. Remote Control includes a variety of device skins 
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from major manufacturers. If your mobile device skin is not in the list of 
packaged skins you can create a new skin or you can check Skin Download 
Manager on the Wavelink web site. For more information about creating new 
skins, refer to  Creating New Skins on page 119.

The Skin Download Manager contains several mobile device skins that you 
can download to the Keymap Editor and use in Remote Control. These skins 
may be created by Wavelink. Other Remote Control users can also create 
skins and then upload those skins to the web site for users to download. For 
more information about packaging a skin you created and uploading it to the 
Skin Download Manager, refer to  Packaging Skins on page 127. 

To download skins:

1 From the Skin menu in the Keymap Editor, select Download from Web.

The Skins Download dialog box appears.

Figure 11-2. Skins Download

2 Click Connect or OK.

You will be connected to the Wavelink Skin Download Center.
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Figure 11-3. Skins Download

3 Select the skin you want to download and click OK.

NOTE For each skin, there may be a number of different keyboard 
configurations. Be sure to select the skin with the keyboard configuration you 
want to use.

The skin files will be downloaded to the \Skins folder in the Remote 
Control installation directory. The skin will appear in the Skin list marked 
with an asterisk.

4 Click the skin to display it in the Keymap Editor.

Importing Skin Files

Once a skin is downloaded, it is automatically visible to the Remote Control, 
Remote Control Console and Keymap Editor. You can open the skin from the 
list of skins, or you can import the skin files into the keymap editor. Skins are 
saved as .xml files.

To import skin files:

1 From the File menu, select New or Open. 
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2 Locate the skin.xml file that you downloaded from the Skins 
Download manager (located in the \Skins folder Remote Control 
installation directory) and click Open.

The file is imported into the Keymap Editor. The device name will appear 
in the device list with all associated images and configurations.

Creating New Skins

When you create a new skin, you need to complete the following tasks before 
using the Keymap Editor to edit the skins.

1 Create an image of the mobile device. Using a graphics design program, 
create an image of the mobile device. This will be the image that appears 
when you connect to the mobile device and display the skin.

2 Create a down image of the mobile device. Using a graphics design 
program, create an image of the mobile device when a key is in the down 
state. The down image can be the same as the main image. 

3 Create a key map. Create a keymap of the mobile device keys/buttons you 
want to configure in the Keymap Editor. You will use this map to 
configure the behavior and actions of key presses in the Remote Control 
connection Each key/button must use a unique color.

NOTE All image files should be saved as .png or .bmp to retain all colors. 

After creating these images you can import them into the Keymap Editor, 
configure the mobile device information associated with that skin, and then 
edit the button actions and behaviors. 

Configuring Skin Information

Before you import the images you want to use for the new mobile device skin 
you should create a new skin file. The skin file contains the device 
information for that specific skin. Remote Control uses this information to 
auto-detect what type of device to which it is connecting.

To configure skin information:

1 From the Skins menu, select New.
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2 In the device information region, enable the Extended Skin option if you 
are creating an extended skin.

Extended skins are skins that have configured keymaps. If you are not 
going to configure a keymap for this skin, do not enable this option.

3 In the Name text box, enter the name of the skin.

Figure 11-4. Skin Information

4 In the OEM Info text box, enter any OEM information you want the 
Remote Control auto detect feature to associate this skin with.

5 In the X and Y text boxes, enter the pixel height and width of the skin.

This is the height and width that the skin will display in the Remote 
Control connection window.

6 Click Apply Changes to save your changes.

Once you have enter information for the mobile device, you are ready to 
import the images of the device that you have created.

Importing Images 

You can import the images you created of the mobile device into the Keymap 
Editor. When you import them they will be available to display in the Remote 
Control connection window when you connect to a mobile device. You can 
import the following types of images:

• Normal. This image is the normal display of the mobile device when it is 
in a stand-by state. This image will display upon a Remote Control 
connection to the mobile device.

• Down. This image displays the mobile device when a key is in the down 
state. This image can be the same as the normal image.
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• Map. This image is the keymap for the mobile device. The image should 
display all the buttons that you want to configure for the mobile device as 
a unique color button. You will use this map image to configure the action 
of each key. 

As you import each image, Normal, Down and Map tabs appear in the 
preview region. You can click each tab to display the specific image. When 
you are finished importing, an Overlay tab appears. You can use this tab to 
compare the Map image to the Normal (actual) image of the mobile device. 
You can verify that the buttons on the map tab fall into place with the actual 
buttons on the mobile device. 

To import images:

1 From the device list, select the device for which you want to import 
images.

2 Click the [...] button next to the Normal text box.

3 Locate the image file you want to import and click Open.

The image will display in the Normal tab.

4 Click the [...] button next to the Down text box.

5 Locate the image file you want to import and click Open.

The image will display in the Down tab.

6 Click the [...] button next to the Map text box.

7 Locate the image file you want to import and click Open.

The image will display in the Map tab.

8 Click Apply Changes to save your changes.

Editing Skins

You can edit existing skins or you can import new skin images into the 
KeyMap Editor for editing and configuration.

This section provides the following information about editing skins:
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• Editing Skin Information

• Configuring Keymaps

• Viewing Split Screen

Editing Skin Information

The skin file contains the device information for that specific skin. Remote 
Control uses this information to detect what type of device it is connecting to 
and then displays the appropriate skin.

To edit skin information:

1 Select a skin from the Skins list.

NOTE If you are creating a new skin, you need to import device images. For 
more information, refer to  Creating New Skins on page 119.

2 In the device information region, enable the Extended Skin option if you 
are creating an extended Skin.

3 In the Name text box, enter the name of the skin.

Figure 11-5. Mobile Device Information

4 In the OEM Info text box, enter any the device OEM information.

This may be the complete OEM string returned by the device or a partial 
string. Remote control will match the complete OEM string, returned by 
the device, with the data entered here. For example, if a device returns 
“My Device 3100” and another device returns “My Device 3110” the OEM 
String “My Device 31” would match both. This is useful when similar 
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devices can share the same keyboard information and slight display 
differences are not significant.

5 In the X and Y text boxes, enter the pixel height and width of the skin 
display in the Remote Control connection window.

6 Click Apply Changes to your changes.

Configuring Keymaps

The Remote Control Keymap Editor allows you to configure the actions and 
behavior of the mobile device keys that display in the Remote Control 
connection window. You use the Map image that you imported to configure 
the different keys. When you import a Map image, the colors and buttons are 
automatically loaded into the Actions Editor region. For more information 
about importing the Map image, refer to  Importing Images on page 120.

To configure keymaps, you complete two tasks:

• Creating Key States. You can set different states that the keys may be in. 

• Configuring Key Actions. You can configure any number of different 
behaviors for each key in the keymap.

Creating Key States

Key states allow you to create many different actions for each mobile device 
key. For example, you can configure a key to perform one action in the normal 
state and a different action when the mobile device is in an ALT-SHIFT state. 
This allows you to configure multiple uses for the same keys. You also have 
the option of making each key a multi-click key. This means that in one state a 
key can perform up to three different actions depending on the number of 
times it is pressed.

To create new device states:

1 In the Actions Editor region, click New.

The New State dialog box appears.
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Figure 11-6. New State

2 Enable the Default option if you want this state to be the default state the 
keys are in when displayed in the Remote Control connection window.

3 Click OK when you are finished.

The new state appears as a tab in the Actions Editor region. 

Configuring Key Actions

You can configure key behavior for each button you created in your keymap 
for the mobile device skin. You have the ability to configure a key to perform 
one action or you can multi-click keys. Multi-click keys can perform up to 
three different actions depending on the number of times it is pressed. You 
also have the ability to create Toggle keys that will toggle the state of the 
mobile device keys. 

To configure key actions:

1 In the Map tab, click the key that you want to configure.

The Edit Key Detail dialog box appears.
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Figure 11-7. Edit Key Detail

2 Enter a Tooltip for the key.

The information you enter into the Tooltip text box will display in the 
Remote Control connection window when you hoover the mouse over that 
key.

3 Select the tab of the key state in which you are going to configure this key.

4 If you want the key to be a multi-click key, enable the Multi Click option.

5 From the On Click drop-down list, select the action you want this key to 
perform on the first click.

You can also enter the code for the action you want the key to perform in 
the Code text box.

6 If you enabled the Multi Click option, configure the On Click 2 and On 
Click 3 options using the drop-down lists.

You can also enter the code for the action you want the key to perform in 
the Code text boxes.

7 If you want this key to toggle the state of the mobile device, say act as the 
shift key, enable the Toggle option.

8 If you enable the Toggle option, enter the state that you want this key to 
toggle to when clicked.
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9 Continue configuring each key in all the states.

10 When you are finished, click OK.

The keys are now configured to perform the actions you configured. 

11 Click Apply Changes to save the key configuration.

Viewing Split Screen

The Keymap Editor allows you to split the preview screen. This way you can 
view different images of the mobile device skin at the same time. For 
example, you can view the color map in one screen and the actual device 
buttons in another.

To view split screen:

• From the View menu, select Split Screen.

Figure 11-8. Split Screen
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Packaging Skins

Only a certain number of skins are included with the Remote Control 
software package. However, you can access and import many other skins at 
the Wavelink web site Skins Download Manager. For more information about 
downloading skins at the Skins Download Manager, refer to  Downloading 
Skins on page 116. Additionally, if you create new skins for mobile devices, 
you can package the skins and upload them to the Wavelink web site for other 
Remote Control users to access.

To send a skin to Wavelink:

1 In the Skins list, select the skin you want to send to Wavelink.

2 From the Skin menu, select Send to Wavelink.

The Upload Skins Package to Wavelink dialog box appears.

Figure 11-9. Upload Skins Package to Wavelink

3 Enter your name in the Name text box.

4 Enter your company in the Company text box.

5 Enter your e-mail in the Email text box.

6 Add any comments about the skin you are sending in the Comments text 
box.
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7 Click OK.

Remote Control will package all the files used to create the selected skin 
and send the package to Wavelink. Wavelink will then post the skin on the 
Skins Download manager allowing other Remote Control users to 
download it.
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Chapter 12: Backing Up and Restoring 
Components

Remote Control provides a backup and restore capability that allows you to 
back up and restore selected Remote Control components. 

Due to the number of files that may be included in the backup, all backup 
files are saved in .zip format. The file is a standard zip file but has a .rcb 
extension. This format makes it easy to capture an existing environment.

The utility allows you to backup and then restore the following Remote 
Control components:

This chapter provides the following information:

• client.dat This component contains client configuration 
settings.

• config.xml This component contains Remote Control connection 
profile entries.

• mobileunits.xml This component contains mobile unit definitions and 
access histories for each device.

• scenarios.xml This component contains scenarios and saved 
scripts.

• skins.xml This component contains device skin definitions.

• licenses.xml This component contains license server definitions 
and client license usage.

• DeviceLogs This component contains audit logs for each device.

• DeviceRegistry This component contains saved registry images for 
each device.

• Recorded_Data This component contains images and .avi files 
from client sessions.

• Skins This component contains downloaded skin 
definitions.

• *.bmp, *.gif, *.jpg, 
*.bmp

This component contains support images for Remote 
Control.
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• Backing Up Remote Control Components

• Restoring Remote Control Components

Backing Up Remote Control Components

You should backup your Remote Control components regularly and before 
uninstalling or upgrading Remote Control.

Backup files are saved as standard zip files with an .rcb file extension, for 
example [filename].rcb.

To backup Remote Control components:

1 In the Tree View of Avalanche Manager, navigate to the software collection 
in which you installed Wavelink Remote Control.

2 Right-click on the WLRMCTL package.

3 Select Configure Package > Backup/Restore Utility.

The RCBackupRestore dialog box appears.

Figure 12-1. RCBackupRestore Dialog Box

4 Click Backup.

The Backup dialog box appears.
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Figure 12-2.  Backup Dialog Box

5 Select the items you wish to backup and then click Backup.

The Enter backup file name dialog box appears.
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Figure 12-3. Enter backup file name Dialog Box

6 Navigate to the location where you want to save your file.

7 Name your backup file and click Open.

The Backup/Restore Progress dialog box appears indicating the progress of 
your backup.

Figure 12-4. Backup/Restore Progress Dialog Box
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8 When the backup is complete, click OK to return to the Backup dialog box.

The Remote Control components you selected to back up are saved as a 
standard zip file with an .rcb extension.

9 You can select to backup more Remote control components or click OK to 
return to the RCBackupRestore dialog box.

10 Click Exit.

Restoring Remote Control Components

After an uninstall or an upgrade, you can restore backed up Remote Control 
components. 

To restore Remote Control components:

1 In the Tree View of Avalanche Manager, navigate to the software collection 
in which you installed Wavelink Remote Control.

2 Right-click on the WLRMCTL package.

3 Select Configure Package > Backup/Restore Utility.

The RCBackupRestore dialog box appears.

Figure 12-5. RCBackupRestore Dialog Box

4 Click Restore.

A standard Open dialog box appears.
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5 Navigate to the location where you saved your Remote Control backup 
file.

6 Select the backup file and click Open.

The Restore dialog box appears.

Figure 12-6. Backup/Restore Progress Dialog Box

7 Select the Remote Control components you want to restore and click 
Restore.

The Backup/Restore Progress dialog box appears indicating the progress of 
your restoration.
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Figure 12-7. Backup/Restore Progress Dialog Box

8 When the restoration is complete, click OK to return to the Backup dialog 
box.

9 You can select to restore other Remote control components or click OK to 
return to the RCBackupRestore dialog box.

10 Click Exit.

The selected components are restored to Remote Control.
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Appendix A: Wavelink Contact Information
If you have comments or questions regarding this product, please contact 
Wavelink Customer Service via email or telephone.

Email: customerservice@wavelink.com

Phone: 425-823-0111
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