# Table of Contents

**Chapter 1: Introduction**

- Document Assumptions .................................................. 3
- Document Conventions .................................................. 4
- About the Screen Reformatter ........................................ 4
  - Overview of the Screen Reformatting Process ..................... 5
  - Screen Reformatter Terminology .................................... 6

**Chapter 2: Understanding the Screen Reformatter**

- Viewing the Screen Reformatter ...................................... 7
  - Initial Screen View .................................................... 7
  - Modified Screen View ................................................ 7
  - Descriptive View ...................................................... 8
    - Screen Verify Criteria ............................................ 9
    - Modified Screen Creation ....................................... 9
    - Supporting Actions ............................................... 9
    - Screen Details ................................................... 9
  - Status Bar .................................................................. 9
  - Tool Bar .................................................................... 10
- Screen Reformatter Menu Options .................................... 10
  - File Menu ................................................................ 11
  - Edit Menu ................................................................ 11
  - View Menu ................................................................ 15

**Chapter 3: Using the Screen Reformatter**

- Basic Tasks ................................................................. 17
  - Capturing a Screen .................................................... 17
  - Accessing the Screen Reformatter .................................. 18
  - Importing a Screen Capture ....................................... 19
  - Exporting a Master File ............................................. 19
  - Importing a Master File ............................................. 20
- Screen Modification ......................................................... 20
  - Copying the Original Screen ....................................... 21
  - Resizing the Modified Screen .................................... 21
  - Adding Text to the Modified Screen ............................. 22
  - Assigning an Initial Field Value ................................... 23
  - Arranging Screen Actions .......................................... 23
  - Navigating Multiple Screens ...................................... 24
  - Adjusting the Screen Position ..................................... 25
- Screen Verification ........................................................ 26
  - Adding Host Profile Verification .................................. 26
  - Adding Text Verification ............................................ 26
  - Adding Cursor Verification ........................................ 27
  - Adding Field Verification .......................................... 27
Arranging Verification Items ............................................ 28
Telnet Feature Support ...................................................... 29
Adding Text-to-Speech Support ........................................... 29
Adding Speech-to-Text Support ........................................... 30
Adding Scripting Support ................................................... 31
Deploying Reformatted Screens ........................................... 32

Appendix A: Wavelink Contact Information .......................... 33

Glossary ............................................................................ 35

Index .................................................................................. 37
Chapter 1: Introduction

This document provides information about using the Telnet Client Screen Reformatter.

This section provides the following information:

• Document Assumptions
• Document Conventions
• About the Screen Reformatter

Document Assumptions

This document assumes that the reader has the following:

• Knowledge of wireless networks and wireless networking protocols.
• Knowledge of TCP/IP, including IP addressing, subnet masks, routing, BootP/DHCP, WINS, and DNS.
• Knowledge of Wavelink Avalanche Manager or Avalanche MC.
• Knowledge of Wavelink Telnet Client.
• Knowledge of Telnet Client Scripting.
• Knowledge of Telnet Client Voice-Enabled Emulation.
Document Conventions

This document uses the following typographical conventions:

**Courier New**

Any time you type specific information into a text box (such as a file name), that option appears in the *Courier New* text style. This text style is also used for any keyboard commands that you might need to press.

Examples:

Type *Enter* to continue.

Press *CTRL+ALT+DELETE*.

**Bold**

Any time you interact with an option (such as a button or descriptions of different options in a dialog box), that option appears in the **Bold** text style.

Examples:

Click *Open* from the *File* Menu.

Select the *Update* option.

**Italics**

Any time this document refers to another section within the document, that section appears in the *Italics* text style. This style is also used to refer to the titles of dialog boxes.

Examples:

See *Status Bar* on page 9 for more information.

The *Screen Reformatter* dialog box appears.

About the Screen Reformatter

The Telnet Client Screen Reformatter is an application that allows you to modify the appearance of Telnet Client emulation screens. You can create a screen layout that includes items you want the mobile device user to see, and does not include items that should not be visible to the user.
The Screen Reformatter does not change the actual emulation screen, only the appearance of the screen displayed to the user. Therefore, any scripts specific to an emulation screen will still work correctly. In addition, any other items specific to an emulation screen will continue to function properly even if they are not visible on the modified screen.

**NOTE** The Screen Reformatter is included in Telnet Client 7.1 and later versions.

**Overview of the Screen Reformatting Process**

The following steps outline the process of modifying Telnet screens using the Screen Reformatter:

1. **Perform a screen capture.** Use the screen capture function within the Telnet Client or Session Monitor to capture any Telnet screen(s) you want to reformat.

2. **Launch the Screen Reformatter.** You can launch the Screen Reformatter from the Telnet Client, Avalanche Manager, or Avalanche MC.

3. **Import the screen capture into the Screen Reformatter.** Import any captured screen(s) you want to reformat.

   -Or-

   **Import a master file into the Screen Reformatter.** You can also import a master file, which contains multiple screen captures.

4. **Reformat the Telnet screen.** Copy the regions of the Telnet screen which you would like to include on the modified screen. You can also modify the screen further by adding things like text, scripts, and speech.

5. **Assign verification items.** You can select a Telnet Host Profile and/or items on the Telnet screen which will be verified to determine whether the reformatted screen should be displayed.

6. **Save the reformatted screen.** After you have modified the screen as desired, you can click the Save icon to save your changes.

   -Or-
Export a master file. If you have reformatted multiple Telnet screens, you can create a master file that contains all of the screens.

7 Connect to the Telnet Client. The file containing the reformatted screen is deployed to the Telnet Client the next time it syncs with Avalanche Manager or Avalanche MC.

Screen Reformatter Terminology

For a complete list of Screen Reformatter terms and components, refer to the Glossary on page 35.
Chapter 2: Understanding the Screen Reformatter

This chapter provides information about the following:

- Viewing the Screen Reformatter
- Screen Reformatter Menu Options

Viewing the Screen Reformatter

The Screen Reformatter is composed of several different sections (or views). In addition, the Screen Reformatter contains status bar and tool bar options.

---

**NOTE** For information about opening the Screen Reformatter, refer to *Accessing the Screen Reformatter* on page 18.

---

The Screen Reformatter consists of the following areas:

- Initial Screen View
- Modified Screen View
- Descriptive View
- Status Bar
- Tool Bar

**Initial Screen View**

The Initial Screen View is the bottom section of the Screen Reformatter. This view displays the screen that was captured, before modifications.

**Modified Screen View**

The Modified Screen View is the top left section of the Screen Reformatter. This view displays the modified version of the captured screen. The Modified Screen View consists of the areas copied from the original screen capture, as well as any added text.
Figure 2-1. Modified Screen View

Descriptive View

The Descriptive View is the top right section of the Screen Reformatter. This view displays information about the Initial Screen and Modified Screen.

Figure 2-2. Descriptive View

The Descriptive View information is divided into the following sections:
Chapter 2: Understanding the Screen Reformatter

- Screen Verify Criteria
- Modified Screen Creation
- Supporting Actions
- Screen Details

**Screen Verify Criteria**
Screen Verify Criteria contains a list of items that are used to determine whether the modified Telnet screen should be displayed. In order for the modified screen to be displayed, all of the text and field verification items must match. If the screen contains multiple cursor or Host Profile verification items, only one must match.

**Modified Screen Creation**
Modified Screen Creation contains a list of actions that will be used to reformat the initial screen.

**Supporting Actions**
Supporting Actions are additional actions performed by the Screen Reformatter when a modified screen is used.

**Screen Details**
Screen Details contains information about the original screen capture.

**Status Bar**
The status bar is located at the bottom of the Screen Reformatter window. You can choose to display or hide the status bar by enabling or disabling the Status Bar option in the View menu.

**NOTE** For more information about using the View menu, refer to View Menu on page 15.

The left side of the status bar displays information about the various menu options and tool bar buttons. The right side of the status bar indicates when the Caps Lock, Num Lock, and Scroll Lock keys have been pressed.
**Tool Bar**

The following table provides information about each Tool Bar button.

- Click this button to access the *Open* dialog box and import a screen capture.
- Click this button to save screen reformatting changes.
- Click this button to undo the last change.
- Click this button to redo the last change.
- Click this button to display the help index.
- Click this button to search for a specific item within the help.

**Screen Reformatter Menu Options**

The Screen Reformatter menus can be used to perform various tasks. This section provides a description of the available options in each of the following:

- File Menu
- Edit Menu
- View Menu
Chapter 2: Understanding the Screen Reformatter

File Menu

This section provides a description of each option in the Screen Reformatter File menu.

Save
Select this option to save the current screen using the same file name.

Import Screen Capture
Select this option to import screens from a screen capture file. Imported screens will be appended to the current master file.

For more information about screen captures, refer to Capturing a Screen on page 17, and Importing a Screen Capture on page 19.

Import Master File
Select this option to import all screens, modifications, and actions saved in a master file. Imported files will be appended to the current master file.

For more information about importing master files, refer to Importing a Master File on page 20.

Export Master File
Select this option to export all screens, modifications, and actions to a master file.

For more information about exporting master files, refer to Exporting a Master File on page 19.

Exit
Select this option to close the Screen Reformatter. You will be prompted to save any unsaved changes.

Edit Menu

This section provides a description of each option in the Screen Reformatter Edit menu.

Undo
Select this option to reverse the last change made.

Redo
Select this option to restore the last change made.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Make Previous Screen</td>
<td>Select this option to move the current screen to the previous position in the master file.</td>
</tr>
<tr>
<td></td>
<td>For more information about screen position, refer to <em>Adjusting the Screen Position</em> on page 25.</td>
</tr>
<tr>
<td>Make First Screen</td>
<td>Select this option to move the current screen to the first position in the master file.</td>
</tr>
<tr>
<td></td>
<td>For more information about screen position, refer to <em>Adjusting the Screen Position</em> on page 25.</td>
</tr>
<tr>
<td>Make Next Screen</td>
<td>Select this option to move the current screen to the next position in the master file.</td>
</tr>
<tr>
<td></td>
<td>For more information about screen position, refer to <em>Adjusting the Screen Position</em> on page 25.</td>
</tr>
<tr>
<td>Make Last Screen</td>
<td>Select this option to move the current screen to the last position in the master file.</td>
</tr>
<tr>
<td></td>
<td>For more information about screen position, refer to <em>Adjusting the Screen Position</em> on page 25.</td>
</tr>
<tr>
<td>Duplicate Screen</td>
<td>Select this option to make a copy of the current screen.</td>
</tr>
<tr>
<td>Delete Screen</td>
<td>Select this option to remove the current screen from the master file.</td>
</tr>
<tr>
<td>Screen Size</td>
<td>Select this option to change the size of the modified screen.</td>
</tr>
<tr>
<td></td>
<td>For more information about adjusting the screen size, refer to <em>Resizing the Modified Screen</em> on page 21.</td>
</tr>
<tr>
<td>Add Text</td>
<td>Select this option to add text to the modified screen.</td>
</tr>
<tr>
<td></td>
<td>For more information about modified screen text, refer to <em>Adding Text to the Modified Screen</em> on page 22.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Edit Text</strong></td>
<td>Select this option to edit any text added to the screen.</td>
</tr>
<tr>
<td><strong>Edit Initial Field Value</strong></td>
<td>Select this option to edit the initial value for the current field.</td>
</tr>
<tr>
<td></td>
<td>For more information about initial field values, refer to <em>Assigning an Initial Field Value</em> on page 23.</td>
</tr>
<tr>
<td><strong>Make Previous Action</strong></td>
<td>Select this option to designate the current action as the previous action in the list.</td>
</tr>
<tr>
<td></td>
<td>For more information about organizing screen actions, refer to <em>Arranging Screen Actions</em> on page 23.</td>
</tr>
<tr>
<td><strong>Make First Action</strong></td>
<td>Select this option to designate the current action as the first action to be performed.</td>
</tr>
<tr>
<td></td>
<td>For more information about organizing screen actions, refer to <em>Arranging Screen Actions</em> on page 23.</td>
</tr>
<tr>
<td><strong>Make Next Action</strong></td>
<td>Select this option to designate the current action as the next action in the list.</td>
</tr>
<tr>
<td></td>
<td>For more information about organizing screen actions, refer to <em>Arranging Screen Actions</em> on page 23.</td>
</tr>
<tr>
<td><strong>Make Last Action</strong></td>
<td>Select this option to designate the current action as the last action to be performed</td>
</tr>
<tr>
<td></td>
<td>For more information about organizing screen actions, refer to <em>Arranging Screen Actions</em> on page 23.</td>
</tr>
<tr>
<td><strong>Delete Action</strong></td>
<td>Select this option to delete the current action.</td>
</tr>
</tbody>
</table>
Add Verify Host Profile
Select this option to add a Host Profile to the modified screen. This will indicate that the modified screen should be displayed each time the specified Host Profile is in use.

For more information about Host Profile verification, refer to Adding Host Profile Verification on page 26.

Edit Verify Host Profile
Select this option to edit any Host Profile added to the modified screen.

Make Previous Item
Select this option to designate the current item as the previous verification item in the list.

For more information about verification items, refer to Screen Verification on page 26.

Make Next Item
Select this option to designate the current item as the next verification item in the list.

For more information about verification items, refer to Screen Verification on page 26.

Make First Item
Select this option to designate the current item as the first to be verified.

For more information about verification items, refer to Screen Verification on page 26.

Make Last Item
Select this option to designate the current item as the last to be verified.

For more information about verification items, refer to Screen Verification on page 26.

Delete Item
Select this option to delete the current verification item.

Add Text-to-Speech Text
Select this option to add text that will be converted into speech when the reformatted screen is used.

For more information, refer to Adding Text-to-Speech Support on page 29.
**Edit Text-to-Speech Text**  Select this option to edit text that will be converted into speech when the reformatted screen is used.

**Add Speech-to-Text**  Select this option to enable speech-to-text conversion on the modified screen.

For more information, refer to *Adding Speech-to-Text Support* on page 30.

**Edit Speech-to-Text**  Select this option to edit the speech-to-text action added to the modified screen.

**Add Scripting Support**  Select this option to add a script that will be executed any time the reformatted screen is used.

For more information about scripts, refer to *Adding Scripting Support* on page 31.

**Edit Scripting Support**  Select this option to change the name of a script.

---

**View Menu**

This section provides a description of each option in the Screen Reformatter View menu.

**Previous Screen**  Select this option to display the previous screen in the master file.

For more information about screen display, refer to *Navigating Multiple Screens* on page 24.

**Next Screen**  Select this option to display the next screen in the master file.

For more information about screen display, refer to *Navigating Multiple Screens* on page 24.

**First Screen**  Select this option to display the first screen in the master file.

For more information about screen display, refer to *Navigating Multiple Screens* on page 24.
<table>
<thead>
<tr>
<th><strong>Last Screen</strong></th>
<th>Select this option to display the last screen in the master file.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>For more information about screen display, refer to <em>Navigating Multiple Screens</em> on page 24.</td>
</tr>
<tr>
<td><strong>Toolbar</strong></td>
<td>Select this option to display or hide the Screen Reformatter Tool Bar. A check mark appears next to the menu option when the Tool Bar is displayed.</td>
</tr>
<tr>
<td></td>
<td>For more information about the Tool Bar, refer to <em>Tool Bar</em> on page 10.</td>
</tr>
<tr>
<td><strong>Status Bar</strong></td>
<td>Select this option to display or hide the Screen Reformatter Status Bar. A check mark appears next to the menu option when the Status Bar is displayed.</td>
</tr>
</tbody>
</table>
| | For more information about the Status Bar, refer to *Status Bar* on page 9.
Chapter 3: Using the Screen Reformatter

This chapter provides information about using the Screen Reformatter, including the following:

- Basic Tasks
- Screen Modification
- Screen Verification
- Telnet Feature Support
- Deploying Reformatted Screens

Basic Tasks

This section provides instructions for basic screen reformatting tasks. The following information is included:

- Capturing a Screen
- Accessing the Screen Reformatter
- Importing a Screen Capture
- Exporting a Master File
- Importing a Master File

Capturing a Screen

Before you can use the Screen Reformatter, you need to capture the screen(s) you wish to reformat. Screen captures are saved as a .wltsc file in the location of your choice.

You may want to consider turning off scroll bars and menus before performing a screen capture. This will ensure that the portion of the screen capture visible on the mobile device more accurately reflects the area of the screen the device user will have to work with.

To capture:

1. From the Telnet Client Option menu, select Logging > Screen Capture.
-Or-

From Session Monitor, select **File > Screen Capture.**

**NOTE** For more information about using Session Monitor, refer to the *Wavelink Telnet Client User Guide.*

The **Screen Capture File** dialog box appears.

2 Navigate to the location where you want to save the screen capture and click **Save.**

The **Screen Capture File** dialog box closes and a check mark appears next to the **Screen Capture** menu item, indicating that screen capturing is enabled.

3 Connect to the desired Host Profile and access the screens that you want to reformat.

4 From the **Option** or **File** menu, select **Screen Capture.**

The screen capture is saved and the check mark next to the **Screen Capture** menu item disappears, indicating that screen capturing is disabled.

**NOTE** Screen capturing is also disabled when you close the Telnet Client.

5 Repeat the preceding steps to capture other screens.

**Accessing the Screen Reformatter**

Access the Screen Reformatter from the Wavelink Telnet Client.

To access from Telnet Windows:

1 Open the Telnet Client.

2 From the **Term** menu, select **Configure > Screen Reformatter.**

   The **Input Password** dialog box appears.

3 Enter the password in the **Input Host Config Password** text box and click **OK.**
The Screen Reformatter opens.

**To access from Telnet CE:**

1. From Avalanche Manager or Avalanche MC, right-click the Telnet Client package.

2. Select **Configure Package > Screen Reformatter** from the menu that appears.

   The Screen Reformatter opens.

---

**Importing a Screen Capture**

Once you have captured the screen(s) you wish to modify, import the screen(s) into the Screen Reformatter.

**To import:**

1. From the **File** menu, select **Import Screen Capture**.

   The **Import Screen Capture** dialog box appears.

2. Navigate to and select the desired `.wltsc` file.

3. Click **Open**.

   The **Screen Reformatter** dialog box appears, indicating the number of unique screens that were added.

---

**Exporting a Master File**

A master file is one that contains several modified screens. You can create a master file by exporting all the screens you have modified.

**To export:**

1. From the **File** menu, select **Export Master File**.

   If you have not saved your modifications, the **Screen Reformatter** dialog box appears, asking if you would like to save your changes.

2. Click **Yes**.

   The **Export Master File** dialog box appears.
3 Navigate to the location where you would like to save the file, and enter a name in the **File Name** text box.

4 Click **OK**.

The *Export Master File* dialog box closes and your master file is saved.

**Importing a Master File**

You can import any master file into the Screen Reformatter for editing purposes.

**To import:**

1 From the **File** menu, select **Import Master File**.

   The *Import Master File* dialog box appears.

2 Navigate to and select the desired *.wlrmf* file.

3 Click **Open**.

   The *Screen Reformatter* dialog box appears, indicating the number of screens that were added.

**Screen Modification**

This section provides instructions for modifying screen captures. The following information is included:

- Copying the Original Screen
- Resizing the Modified Screen
- Adding Text to the Modified Screen
- Assigning an Initial Field Value
- Navigating Multiple Screens
- Adjusting the Screen Position
Chapter 3: Using the Screen Reformatter

**Copying the Original Screen**

After you have imported the screen(s) you wish to configure, copy the regions you would like to modify.

**To copy:**

1. Click and drag the mouse over the area you wish to copy.

![Figure 3-1. Copying a Region](image)

When you release the left mouse button, a menu list appears.

2. Select one of the following options:

   - **Copy Region** to copy the selected region to the Modified Screen View.
   - **Text-to-Speech Copy** to copy a text-to-speech action to the Modified Screen View.
   - **Unselect Area** to discard the region selection.

   If you select **Copy Region**, the Reformatted Screen Copy Attributes dialog box appears.

3. If you want an identical copy of the selected region, enable the **Do not change the attributes** option.
4 If you want to customize the text in the selected region, enable the Use these custom attributes option.

The following options become available:

- **Only use when the cursor is in the copied area** checkbox. Enable this option to ensure that the specified attributes are used only when the cursor is in the copied region.

- **Foreground Color** and **Background Color** drop-down menus. You can edit the appearance of the text by selecting the desired colors from these menus.

- **Weight** drop-down menu. You can edit the appearance of the text by selecting the desired weight from this drop-down menu.

- **Italicized, Underlined, Crossed Out, Reversed, Blinking** checkboxes. You can further alter the text appearance by enabling any or all of these checkboxes.

5 When you are finished editing the text, click OK.

The Reformatted Screen Copy Attributes dialog box closes and the copied region appears in the Modified Screen View.

**Resizing the Modified Screen**

You can adjust the size of the modified screen to fit your needs.

**To resize:**

1 From the Edit menu, select **Screen Size**.

   - Or-

   In the Modified Screen View, right-click and select **Screen Size** from the menu that appears.

   The Modified Screen Size dialog box appears.

2 Adjust the numbers in the **Rows** and **Columns** text boxes and click OK.

   The Modified Screen Size dialog box closes, and the screen size adjusts.
3 You can also adjust the screen size by clicking and dragging the sides of the screen in the Modified Screen View.

**Adding Text to the Modified Screen**

If desired, you can add text that will appear on the modified screen.

**To add text:**

1. From the *Edit* menu, select *Add Text*.

   -Or-

   In the Modified Screen View, right-click and select *Add Text* from the menu that appears.

   The *Reformatted Screen Text* dialog box appears.

2. Enter your text in the available text box.

3. Edit the appearance of the text by selecting a color from the *Foreground Color* and *Background Color* drop-down menus.

4. From the *Weight* drop-down menu, select either *Normal*, *Bold*, or *Faint*.

5. You can further alter the text appearance by enabling any or all of the following checkboxes:

   - *Italicized*
   - *Underlined*
   - *Crossed Out*
   - *Reversed*
   - *Blinking*

6. When you are finished editing the text, click *OK*.

   The *Reformatted Screen Text* dialog box closes, and the text appears in the Modified Screen View.

7. To make changes to existing text, right-click the text and select *Edit Text* from the menu that appears.
**Assigning an Initial Field Value**

You can specify an initial value that will be assigned to a field when the modified screen is used.

**To assign:**

1. In the Initial Screen View, right-click on the field to which you want to assign an initial value.

2. Select *Add Field Initial Value* from the menu that appears.
   
   The *Initial Field Value* dialog box appears.

3. Enter the desired field value in the available text box and click OK.

   The *Initial Field Value* dialog box closes and the initial value is assigned.

**NOTE** The Screen Reformatter does not verify any field data. You must ensure that the information you enter is valid for that field.

**NOTE** The initial field value will be assigned even if the field is not copied to the modified screen.

**Arranging Screen Actions**

When you have multiple actions on the modified screen, you can determine the order in which the actions occur.

**To arrange actions:**

1. Select the desired action in the Modified Screen View.

1. Click the *Edit* menu.
   
   - Or-
   
   Right-click in the Initial Screen View.

   A menu list appears.

2. Select one of the following options:
Chapter 3: Using the Screen Reformatter

- **Make First Action** to designate the current action as the first action to be performed.

- **Make Next Action** to designate the current action as the next action in the list.

- **Make Previous Action** to designate the current action as the previous action in the list.

- **Make Last Action** to designate the current action as the last action to be performed.

- **Delete Action** to remove the current action.

**NOTE** If two actions overlap, the latter action will be visible.

**Navigating Multiple Screens**

If you are modifying more than one screen, you can navigate to different screens in a master file.

**To change screens:**

1. Click the **View** menu.
   - Or-
   
   Right-click in the Initial Screen View.
   
   A menu list appears.

2. Select one of the following options:

   - **First Screen** to display the first screen in the master file.
   
   - **Next Screen** to display the next screen in the master file.
   
   - **Previous Screen** to display the previous screen in the master file.
   
   - **Last Screen** to display the last screen in the master file.
Adjusting the Screen Position

When you are modifying multiple screens, you can determine the order in which they appear in the master file.

To arrange screens:
1 Select the desired screen and click the Edit menu.
2 Select the screen position from the menu list that appears.
   • Make First Screen if you want the current screen to be the first screen in the master file.
   • Make Next Screen if you want the current screen to be in the next position in the master file.
   • Make Previous Screen if you want the current screen to be in the previous position in the master file.
   • Make Last Screen if you want the current screen to be the last screen in the master file.
   • Delete Screen to remove the current screen.
3 Perform the preceding steps for each screen in the master file.

NOTE For information about navigating to a different screen, refer to Navigating Multiple Screens on page 24.

Screen Verification

The Screen Reformatter gives you the ability to specify items on the original Telnet screen that must be verified before the modified screen will be displayed. This section includes instructions for the following:

• Adding Host Profile Verification
• Adding Text Verification
• Adding Cursor Verification
• Adding Field Verification
• Arranging Verification Items

Adding Host Profile Verification

You can specify a certain Telnet Host Profile to be used with the modified screen. This will ensure that the modified screen will only be displayed when the specified Host Profile is in use.

To add a Host Profile:
1. From the Edit menu, select Add Verify Host Profile.

   -Or-

   In the Initial Screen View, right-click and select Verify Host Profile from the menu that appears.

   The Host Profile Verification dialog box appears.

2. Select the desired Host Profile from the drop-down menu and click OK.

   The Host Profile Verification dialog box closes and the Host Profile verification is added.

Adding Text Verification

You can select a certain text item on the original Telnet screen that must be verified before the modified screen is displayed to a mobile device user.

To add text verification:
1. Click and drag the mouse over the text you want to verify.

   When you release the left mouse button, a menu list appears.

2. Select Verify Text.

   The text verification item appears in the Screen Verify Criteria section of the Descriptive View window.

NOTE The selected text will still be verified even if it is not copied to the modified screen.
Adding Cursor Verification

You can also select a specific cursor location on the original Telnet screen that must be verified before the modified screen is displayed to a mobile device user.

To add cursor verification:
1. Click and drag the mouse over the cursor location you want to verify.
   
   When you release the left mouse button, a menu list appears.

2. Select Verify Cursor.
   
   The cursor verification item appears in the Screen Verify Criteria section of the Descriptive View window.

NOTE The selected location will still be verified even if it is not copied to the modified screen.

Adding Field Verification

You can select a specific field on the original Telnet screen that must be verified before the modified screen is displayed to a mobile device user.

To add field verification:
1. Right-click on the field you want to verify.

2. Select Verify Field from the menu that appears.

   The field verification item appears in the Screen Verify Criteria section of the Descriptive View window.

NOTE The selected field will still be verified even if it is not copied to the modified screen.

Arranging Verification Items

When you have multiple items on the modified screen, you can determine the order in which the items are verified.
To arrange items:

1. Select the desired item in the Initial Screen View.

2. Click the **Edit** menu.
   - Or-
   Right-click in the Initial Screen View.
   A menu list appears.

3. Select one of the following options:
   - Select **Make First Item** to designate the current item as the first to be verified.
   - Select **Make Next Item** to designate the current item as the next verification item in the list.
   - Select **Make Previous Item** to designate the current action as the previous verification item in the list.
   - Select **Make Last Item** to designate the current item as the last be verified.
   - Select **Delete Item** to remove the current verification item.

**Telnet Feature Support**

The Screen Reformatter allows you to add support for Telnet features such as Voice-Enabled Emulation and Scripting. This section provides information about adding support, including the following:

- Adding Text-to-Speech Support
- Adding Speech-to-Text Support
- Adding Scripting Support

**Adding Text-to-Speech Support**

You can add text to the modified screen that will be converted into speech and played back to the mobile device user.
**To add text-to-speech:**

1. From the **Edit** menu, select **Add Text-to-Speech Text**.

   -Or-

   In the Initial Screen View, right-click and select **Add Text-to-Speech** from the menu that appears.

   The *Text-to-Speech Text* dialog box appears.

2. Enter your text in the available text box and click **OK**.

   The *Text-to-Speech Text* dialog box closes and your text is added to the screen.

You can also copy existing text from the original screen that will be converted into speech and played back to the mobile device user.

**To copy text-to-speech:**

1. Click and drag the mouse over the text you want to copy.

   When you release the left mouse button, a menu list appears.

2. Select **Text-to-Speech Copy**.

   The Text-to-Speech action appears in the Supporting Actions section of the Descriptive View window.

---

**NOTE** If there are multiple text-to-speech actions in a row, all text will play as a single sentence without any pauses or breaks.

---

**Adding Speech-to-Text Support**

You can also add a speech-to-text action to the modified screen. This action will convert the user’s speech into text that will be processed according to the grammar specified.

**To add speech-to-text:**

1. From the **Edit** menu, select **Add Speech-to-Text**.

   -Or-
In the Initial Screen View, right-click and select Add Speech-to-Text from the menu that appears.

The Speech-to-Text Support dialog box appears.

2 Enter the exact name of the grammar file in the Speech-to-Text Grammar to use text box.


3 If desired, select a key from the Additional keypress after result drop-down menu. The specified keypress will be processed after the speech-to-text action.

4 If you would like the Speech-to-Text engine to verify the text result, enable the Verify Result checkbox and enter the following information:
   - Enter a question in the Verification Question text box.
   - Enter a grammar name in the Verification Grammar to use text box.
   - Enter a response in the Grammar Response if Right text box.
   - Enter a response in the Text-to-Speech if Right text box.
   - Enter a response in the Text-to-Speech if Wrong text box.
   - Enter a number (in seconds) in the Timeout text box.

5 If you are not using a headset microphone, enable the Delay Speech-to-Text to avoid feedback checkbox. This will ensure that the microphone does not pick up text-to-speech sounds from the mobile device.

6 Click OK.

The Speech-to-Text Support dialog box closes and the speech-to-text action is added to the modified screen.
Adding Scripting Support

If desired, you can designate a script to run when the modified screen is first displayed. The script can provide additional functionality to the modified screen.

To add a script:

1. From the Edit menu, select Add Scripting Support.

   -Or-

   In the Initial Screen View, right-click and select Add Scripting Support from the menu that appears.

   The Scripting Support dialog box appears.

2. Select the desired script from the Script to launch drop-down menu.

   **NOTE** The Script to launch drop-down menu only displays scripts that have been saved in the Telnet Client Script Editor. For more information about Telnet Client Scripting, refer to Wavelink Telnet Client Scripting Reference Guide.

3. If you want to ensure that the script does not run multiple times, enable the Don’t launch the script if it is already running checkbox.

4. If you want the script to abort when the modified screen is no longer in use, select the Stop the script when reformatting changes option.

5. Click OK.

   The Scripting Support dialog box closes and the script is added to the screen.

Deploying Reformatted Screens

Once you have finished modifying your screen, click the Save icon to save your screen, and then exit the Screen Reformatter. Your Telnet Client will update with the new screen the next time the device syncs with Avalanche Manager or Avalanche MC.
Appendix A: Wavelink Contact Information

If you have comments or questions regarding this product, please contact Wavelink Customer Service via e-mail or telephone.

**Email:** customerservice@wavelink.com

**Phone:** 1-888-699-WAVE (9283)
### Glossary

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Action</strong></td>
<td>A single step taken by the Screen Reformatter.</td>
</tr>
<tr>
<td><strong>Descriptive View</strong></td>
<td>The top right section of the Screen Reformatter. This view displays information about the Initial Screen and Modified Screen.</td>
</tr>
<tr>
<td><strong>Initial Field Value</strong></td>
<td>A value applied to a field whenever the modified screen is used.</td>
</tr>
<tr>
<td><strong>Initial Screen View</strong></td>
<td>The bottom section of the Screen Reformatter. This view displays the screen that was captured, before modifications.</td>
</tr>
<tr>
<td><strong>Master file</strong></td>
<td>A file that contains several modified screens. Master files are identified by a .wlrmf file extension.</td>
</tr>
<tr>
<td><strong>Modified Screen View</strong></td>
<td>The the top left section of the Screen Reformatter, consisting of the areas copied from the original screen capture, as well as any added text. This view displays the modified version of the captured screen.</td>
</tr>
<tr>
<td><strong>Result</strong></td>
<td>The return value of a function.</td>
</tr>
<tr>
<td><strong>Return</strong></td>
<td>A statement that ends the processing of the current function and returns control to the calling function, with or without a return value.</td>
</tr>
<tr>
<td><strong>String</strong></td>
<td>An ordered sequence of symbols chosen from a predetermined set.</td>
</tr>
<tr>
<td><strong>Telnet</strong></td>
<td>A TCP/IP utility used for terminal emulation, which allows a client to connect to and interact with a remote host system.</td>
</tr>
<tr>
<td><strong>Verification Item</strong></td>
<td>An item on the original Telnet screen that must be verified before the modified screen will be displayed.</td>
</tr>
</tbody>
</table>
# Index

## A
- about Screen Reformatter 4
- accessing Screen Reformatter 18
- actions, arranging 23
- adding
  - cursor verification 27
  - field verification 27
  - host profile verification 26
  - scripting support 31
  - speech-to-text support 30
  - text 22
  - text verification 26
  - text-to-speech support 29
- adjusting, screen position 25
- arranging
  - actions 23
  - verification items 28
- assigning, initial field value 23
- assumptions, document 3

## B
- basic tasks 17

## C
- capturing, screens 17
- contact information 33
- conventions, document 4
- copying, original screen 21
- cursor verification, adding 27

## D
- deploying reformatted screens 32
- descriptive view 8
  - modified screen creation 9
  - screen details 9
  - screen verify criteria 9
  - supporting actions 9
- document

## E
- assumptions 3
- conventions 4

## F
- edit menu 11
- exporting, master file 19

## G
- feature support, Telnet 29
- field value, assigning 23
- field verification, adding 27
- file menu 11

## H
- glossary 35

## I
- host profile verification, adding 26

## M
- importing
  - master file 20
  - screen capture 19
- initial field value, assigning 23
- initial screen view 7
- introduction 3

## Master file
- exporting 19
- importing 20
- menues
  - edit 11
  - file 11
  - view 15
- modification, screen 20
- modified screen creation, descriptive view 9
- modified screen view 7
modified screen, resizing 21
multiple screens, navigation 24

N
navigating, multiple screens 24

O
original screen, copying 21
overview 5

R
reformatted screens, deploying 32
resizing, modified screen 21

S
saving, master file 19
screen capture
  capturing 17
  importing 19
screen details, descriptive view 9
screen modification 20
screen position, adjusting 25
Screen Reformatter
  about 4
  accessing 18
  basic tasks 17
  menu options 10
  overview 5
  terminology 6
  understanding 7
  using 17
  viewing 7
screen verification 26
screen verify criteria, descriptive view 9
scripting, adding support 31
speech-to-text, adding support 30
status bar 9
support
  scripting 31
  speech-to-text 30

T
Telnet features 29
text-to-speech 29
supporting actions 9

T
Telnet feature support 29
terminology 6
text
  adding 22
  verifying 26
text verification, adding 26
text, adding 22
text-to-speech, adding support 29
tool bar 10

U
understanding Screen Reformatter 7
using, Screen Reformatter 17

V
verification 26
  arranging items 28
  cursor 27
  field 27
  host profile 26
  text 26
verification items, arranging 28
view menu 15
view windows
  descriptive view 8
  initial screen view 7
  modified screen view 7
viewing Screen Reformatter 7

W
Wavelink contact information 33