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Chapter 1: Introduction
Remote Control allows you to connect to, view, and control mobile devices from the 
Avalanche Console. With Remote Control, an administrator can remotely diagnose and fix 
both applications and device settings, or provide guidance for a device user. This reduces 
mobile device down-time and increases productivity. Remote Control can also be used for 
presenting software to an audience, rapid data entry, or automated software testing. 

This section contains the following information:

• Remote Control Components

• About This Guide

Remote Control Components
Remote Control has the following components: 

• Remote Control Server. The Remote Control Server facilitates network connections for 
Remote Control. You can configure server connection settings and set up the SMS e-mail 
gateway from the Remote Control Console.

• Remote Control Client. The client portion of Remote Control is deployed to a mobile 
device as an Avalanche package and runs automatically when you start-up or reboot the 
device.Once you download the Remote Control package to the mobile device, you can 
configure a limited number of client settings from the device.

• Remote Control Standard Viewer. The Standard Viewer allows you to interact with a 
remote device you are connected to. The Standard Viewer is accessed through the 
Avalanche Java Console.

• Remote Control Web Viewer. The Remote Control Web Viewer allows you to interact 
with a remote device through a web browser. The Remote Control Web Viewer is accessed 
through the Avalanche Web Console. 

NOTE:  You cannot connect to the same device with both the Web Viewer and the Standard 
Viewer at the same time. 

• Remote Control Console. The Remote Control Console allows you to configure server 
settings. 

• Skins Editor. The Skins Editor allows you to import device skin images you download or 
create and then assign keymaps to the skins. When a skin is associated with a connection, 
an image of the device is displayed along with the screen, and you can click on device 
buttons to perform tasks.
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About This Guide
This guide assumes that the user is familiar with Avalanche and the wireless hardware in use.

This document uses the following typographical conventions:

Courier 
New

The Courier New font is used for any keyboard commands, filenames, and file 
paths. It is also used for any information you need to type in text boxes.

Examples:

Navigate to C:\deploy.

Press CTRL+ALT+DELETE.

Bold Any time this document refers to an option, such as options in a dialog box, that 
option appears in the Bold text style.

Example:

Click File > Open.

Italics Any time this document refers to the titles of dialog boxes, that section appears in 
the Italics text style. 

Example:

The Infrastructure Profiles dialog box appears.
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Chapter 2: Installing Avalanche Remote Control
Remote Control comes as two separate files: the Remote Control Server installation file (.exe) 
and the Remote Control software package (.ava). The installation file installs the Remote 
Control server on a local computer. The Remote Control software package contains the client 
software that needs to be installed on the mobile device. The software package must be added 
to an Avalanche profile before it can be configured and deployed to the device. 

This section provides the following installation information:

• System Requirements

• Installing the Remote Control Server on Windows

• Installing the Remote Control Server on Linux

• Installing and Configuring the Client

• Installing the Remote Control Skins Editor

NOTE:  Use of Remote Desktop or other terminal services in conjunction with Wavelink 
Avalanche Remote Control is not recommended.

System Requirements
There are two sets of requirements necessary to install and run Avalanche Remote Control: for 
installing the Remote Control Server and for installing the Remote Control Client. You must 
have Avalanche 5.2 or later (either Mobility Center or Site Edition) installed in order to use 
Remote Control 4.1. Wavelink recommends installing Remote Control local to the Enterprise 
Server database.

Client System Requirements

• Avalanche Enabler 3.50-12 or later versions

• Windows CE (4.2 or later), PocketPC 2003, Windows Mobile (5.0 or later), Windows XP or 
Windows XP embedded devices, or Windows 7

• 200 KB of disk space

• 200 KB of Flash memory 
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Server System Requirements 

OS Windows XP Professional 32 bit

Windows Vista 32 or 64 bit

Windows 2003 Server 32 bit

Windows 2008 Server 32 or 64 bit

Windows 2008 Server R2 32 or 64 bit

Windows 7 32 or 64 bit

Linux 2.4 or 2.6 kernel 
(Red Hat 7.3 or Red Hat Enterprise 4 are recommended)

 1-1000 Simultaneous Connections

CPU Single Core at 2.8 GHz or greater

RAM (minimum)

(recommended)

2 GB

3 GB (using a 32-bit OS) or 4 GB (using a 64-bit OS)

Disk Space (minimum)

(recommended)

4 GB

8 GB

Installing the Remote Control Server on Windows
The Remote Control Server installation file installs the Remote Control Server. The Remote 
Control software package and Client are installed separately. 

NOTE:  Previous versions of Remote Control should be removed before Remote Control 4.1 
is installed. 

To install the Remote Control Server:

1  Obtain the Remote Control Server installation file and save it on the system where you 
want to install the Remote Control Server.

2  Double-click the Remote Control Server installation file.

A Welcome dialog box appears.

3  Click Next.

The Remote Control Server Password screen appears.
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4  Provide a username and password to use to access the Remote Control Console and click 
Next. 

The License Agreement screen appears.

5  Agree to the terms of the license and click Next.

The Select Destination Location screen appears.

6  Click Next to accept the default installation folder, or click Browse to navigate to a folder of 
your choice. After you select an installation folder, click Next to continue the installation 
process. 

The Select Start Menu Folder screen appears.

7  Click Browse to navigate to and select the folder where you want to create Remote Control 
shortcuts in the Start menu. 

8  Click Next.

The Ready to Install screen appears. 

9  Click Install to begin the installation.

The Remote Control Setup Wizard installs Remote Control. 

If Remote Control is not installed local to the Avalanche Enterprise Server, you must 
configure Remote Control to access the license server. For information on configuring the 
Remote Control Server, see Synchronizing with the Avalanche License Server on page 12. 

10  To close the installation wizard, click Finish.

Installing the Remote Control Server on Linux
The Remote Control Server installation file installs the Remote Control Server. The Remote 
Control software package and Client are installed separately. 

To install the Remote Control Server:

1  Modify the firewall to allow Remote Control traffic. For information on Remote Control 
port usage, see Ports List on page 64.

2  Create a directory where Remote Control will be installed.

3  Extract the Remote Control tar file to the directory with the following command:

-tar -xvf [filename].tar

where [filename] is the name of the Remote Control tar file.
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4  Navigate to the Remote Control directory that was created in the installation 
directory.

5  To start the server, type ./wlrcserv.sh

The service will run as long as the window is open. For instructions on configuring 
Remote Control, see Using the Remote Control Console on page 11. 

Installing and Configuring the Client
To install the Remote Control client on the mobile device, add the package to a new or existing 
Avalanche software profile. After the package has been added to a profile, you can enable, 
configure, and deploy it to mobile devices. For details about creating and deploying software 
profiles or adding software packages in Avalanche SE or MC, see the Avalanche user guide.

When you configure the software package, you have options to configure skin and logging 
options, a password to connect to the device, notification policies, and connection options 
such as the server address and client preconnect. For more information on configuring the 
Client from Avalanche, see Editing the Remote Control Package on page 18.

Installing the Remote Control Skins Editor
The Remote Control Skin Editor installation file installs the utility to edit Remote Control skins. 

To install the Remote Control Skins Editor:

1  Obtain the Remote Control Skins editor installation file and save it on the system where 
you want to install.

2  Double-click the installation file.

A Welcome dialog box appears.

3  Click Next.

The License Agreement screen appears.

4  Agree to the terms of the license and click Next.

The Select Destination Location screen appears.

5  Click Next to accept the default installation folder, or click Browse to navigate to a folder of 
your choice. After you select an installation folder, click Next to continue the installation 
process. 

The Select Start Menu Folder screen appears.
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6  Click Browse to navigate to and select the folder where you want to create Remote Control 
shortcuts in the Start menu. 

7  Click Next.

The Ready to Install screen appears. 

8  Click Install to begin the installation.

The Remote Control Setup Wizard installs the Skins Editor. 

9  To close the installation wizard, click Finish.
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Chapter 3: Licensing
Remote Control requires one license for each mobile device it manages. You can access and 
configure the Remote Control Console without a license, but you will not be able to 
communicate with a mobile device. 

Licensing for Remote Control is handled through Avalanche. The Avalanche License Server is 
responsible for supplying licenses to Remote Control mobile devices. Before you can use 
Remote Control, you must activate your Remote Control licenses through Avalanche and 
provide Remote Control with the address of the License Server. 

This section provides the following licensing information:

• Types of Licenses

• Activating Remote Control Licenses

• Activating Demo Mode

NOTE:  For information on configuring Remote Control to contact the license server, see 
Synchronizing with the Avalanche License Server on page 12.

Types of Licenses
Remote Control requires a license for each mobile device it manages. When a Mobile Device 
Server detects a new wireless device, a license request is sent to the License Server. The 
License Server then sends a license to the Mobile Device Server to be distributed. The license 
file is unique to the server and cannot be transferred to another server. Once the device 
receives the license, Remote Control can connect to that device. If a license expires or is 
released, the license returns to the pool of licenses at the License Server until it is requested by 
another server.

NOTE:  The License Server uses TCP port 7221. For the License Server to function properly, 
this port must be open and not blocked by a firewall. 

There are two types of licenses available with Remote Control: base and maintenance. Base 
licenses are required to manage devices when using any variety of Remote Control version 4 
(4.x). You will also need maintenance licenses if you have upgraded beyond version 4.1. For 
example, if you upgraded to 4.5, you would need a 4.x base license and a maintenance license 
for each device you want to manage. 

Base licenses do not expire. Maintenance licenses are valid through a specific date. For users’ 
convenience, some licenses may come with a license start date. You can activate these licenses 
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and they will appear in the Licensing dialog box, but the License Server will not be able to 
distribute them until the date specified.

NOTE:  To obtain Remote Control licenses, please contact Wavelink Customer Service.

Activating Remote Control Licenses

In order to use your licenses for Remote Control, you need to activate them through the 
Avalanche Console.

To activate Remote Control:

1  Obtain the Avalanche product licensing code from Wavelink.

NOTE:  You receive this information in an e-mail from Wavelink upon purchasing Remote 
Control.

2  From the Avalanche Java Console, click Tools > Manage Licensing.

The Licensing dialog box appears.

Licensing dialog box

3  Click Add a License.

The Add a License dialog box appears.

4  Click Activate a License.

The Activate a License dialog box appears.

5  Type the Product License in the text box and click Activate.

Avalanche connects with a secure Wavelink Web site and your license is verified. The 
licenses appear in the Licensing dialog box.
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Activating Demo Mode
If you are installing Remote Control for demonstration purposes, you can run the product in 
demo mode. When you activate Demo Mode in Avalanche, you activate all the demo licenses 
for that installation. Demo mode includes 2 base licenses for Remote Control.

To activate demo mode:

1  Access the Licensing dialog box from the Avalanche Console by clicking Tools > Manage 
Licensing.

The Licensing dialog box appears.

2  Click Demo Licenses.

Avalanche and Remote Control will run in demo mode. Once demo mode has been 
activated on one Console, no other Console connecting to the Enterprise Server will be able 
to activate demo mode. 
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Chapter 4: Using the Remote Control Console
The Remote Control Console allows you to configure options for connecting to Avalanche, 
configuring the client, downloading and using skins, and viewing system information. Access 
to the Remote Control Console is limited by Avalanche user permissions. Only an Avalanche 
Administrator user will be able to view all of the options. 

Some Avalanche server information must be configured before you can connect a device or 
manage package options. When you finish installing Remote Control, the installation process 
will automatically launch a browser window, or you can navigate to the Remote Control 
Console using the browser's address bar. 

Once you have completed the initial configuration, you can configure the following options 
from the Remote Control Console:

• Changing the Username and Password

• Synchronizing with the Avalanche License Server

• Configuring Server Options

• Configuring Skin Settings for the Server

• Managing Cell Carriers

• Backing Up and Restoring the Remote Control Database

• Viewing System Information

• Configuring Connection Profiles

To log in to the Remote Control Console:

1  From the computer where the Remote Control server is installed, click 
Start > Programs > Remote Control 4.1 > Server Setup. 

-Or-

From the Avalanche Console, select the software profile that has the Remote Control 
package. When you click to configure the package, the Configure Software Package dialog 
box appears. Select Server Configuration from the list and click Launch Config.

2  Log in using the username and password configured during installation. 

The Remote Control Console appears. 
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Changing the Username and Password
The Remote Control Administrator user account is required to log in when you first configure 
the server from a web browser. The default username is admin and the default password is 
admin. Wavelink recommends you change at least one of these. You must log in using the 
account (or an Administrator Avalanche account) in order to change it. 

After you have completed the initial configuration of Remote Control and provided the 
database address and password, use your Avalanche username and password to log in to 
Remote Control. Avalanche user permissions will be enforced. Only an Avalanche 
Administrator will be able to view the Setup or System menus. 

To change the Remote Control Administrator username and password:

1  From the Remote Control Console, click Password in the System Menu.

2  Type the new username and password in the text boxes. When you change the password, 
you must type it a second time in the Retype Password text box to confirm that it is 
correct.

3  Click Save. 

Synchronizing with the Avalanche License Server
Remote Control must connect to the Avalanche license server in order to distribute licenses. 
The port 7221 should be unblocked between the Remote Control server and the Avalanche 
license server. The Avalanche license server is usually installed at the same location as the 
enterprise server. Configure the Avalanche server address for Remote Control after the server 
is installed from the Remote Control Console. 

You can check to ensure the Remote Control server can contact the Avalanche license server 
from the Remote Control Console.

To configure the license server information from a web browser:

1  From the Remote Control Console, click Licensing in the System Menu.

2  Type the address of the Avalanche server in the License Server text box. The default Port 
for the license server is 7221. 

3  Click Verify to check if Remote Control can contact the license server.

4  Click Save.

Configuring Server Options
The Remote Control web page allows you to configure the schedule that Remote Control uses 
to sync with Avalanche and the Wavelink skins repository. It also allows you to configure the 
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e-mail gateway for Remote Control, the mail server (either POP3 or SMTP) credentials  and log 
setting, the device timeout settings, and the VNC settings. 

The Server Setup page has the following options:

Wavelink Sync tab                         

Enable Sync Enables or disables the Remote Control synchronization with the 
Wavelink skins repository. 

Schedule Schedules when Remote Control syncs with the Wavelink skins 
repository. The default value means that Remote Control will sync 
daily at 1 AM. Use a cron expression format. 

Skins Repository The address for the Wavelink skins repository. 

Wide Area tab                         

Host The DNS name of the mail server.

Mail From The address that will appear in the From field of the e-mail. 

POP3 Host The DNS name of the POP3 host.

User The user name for the POP3 server.

Password The password for the POP3 server.

Pop Before 
SMTP

When this is enabled, Remote Control will try to use the POP3 server 
before it attempts SMTP.

User The user name for the SMTP server.

Password The password for the SMTP server.

Port The port used by the SMTP server.

Use Auth Determines if authentication credentials are sent to the outgoing mail 
server.

Debug Mail 
Session

Enables or disables a Remote Control log for sending mail. 

Timeouts tab                         

TCP How long to wait (in milliseconds) before the TCP connection request 
times out. 
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Send 
UDP Requests

If the server will attempt to use UDP to request the device to connect.

UDP How long to wait (in milliseconds) before the UDP connection request 
times out. 

SMS How long to wait (in milliseconds) before the SMS connection request 
times out. 

Web Session The length of time (in seconds) before the connection to the Remote 
Control Console will time out. 

VNC tab                         

Quality The quality of the Remote Control display. This is on a scale of 1-100, 
where 100 is the best quality and 1 is the worst quality.

Device Refresh How often the device screen is refreshed during a Remote Control 
session.

Viewer Refresh How often the viewer screen is refreshed during a Remote Control 
session. 

Alt Server tab                         

Use Alternate 
Server

Specifies that the Remote Control Console should be launched using a 
local server address. This option only needs to be enabled when the 
server address in the Client Settings is a publicly available IP address. 
(For example, if the device is using a WWAN address.)

Server Address Specifies the local Remote Control server address to use for launching 
the Remote Control Console. 

To configure server options from the Remote Control web page:

1  Launch the Remote Control Console using the username configured during installation.

2  Click Server Setup in the System Menu.

3  Configure the settings as needed.

4  Click Save.

Configuring Skin Settings for the Server
The Remote Control web page allows you to enable automatic skin synchronization, view 
available skins, or download skins from the Wavelink server. 

To enable automatic skin synchronization:

1  From the Remote Control Console, click Skins in the System Menu.
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2  Click the Auto Sync tab.

3  Select Yes from the drop-down menu and click Update.

To view the skins available on your computer:

1  From the Remote Control Console, click Skins in the System Menu.

2  Click the Available tab.

3  Select the brand name to view all skins for that brand, or click Expand in the top right 
corner to view all skins for all brands. 

To download skins:

1  From the Remote Control Console, click Skins in the System Menu.

2  Click the Download tab.

3  Select the brand name to view all skins for that brand, or click Expand in the top right 
corner to view all skins for all brands. When you find the skin you want, click Download. 

Managing Cell Carriers
If you are using an e-mail gateway for SMS messages, select a default cellular provider for the 
messages to be sent through. If your carrier is not in the list, you can add it. 

NOTE:  If you have some devices that use a different carrier, you can configure the carrier 
on a per-device basis from the Remote Control Client.

To select your cellular provider for SMS messages:

1  From the Remote Control Console, click Carriers in the System Menu.

2  Use the Default drop-down menu to select your provider.

3  If your carrier is not in the list, click Add New. 

4  Type the Name, Email Address, and the Max Length of the text message in the text boxes 
and click Update. The carrier will be added to the list. 

NOTE:  For examples of the e-mail address format, you can view the details of carriers that 
have already been configured.

Backing Up and Restoring the Remote Control Database
Remote Control maintains its own database of device information separate from the Avalanche 
databases. The Remote Control web page allows you to back up and restore the 
Remote Control database. Database backups can be exported to another system for storage or 
for redundancy. 
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To back up the Remote Control database:

1  From the Remote Control Console, click Backup in the System Menu.

2  Click Backup. 

3  A backup is created locally. 

To restore a Remote Control database backup:

1  From the Remote Control Console, click Backup in the System Menu.

2  In the Restore area, select the backup that you want to restore. Click Restore. 

To export or import a backup file:

1  From the Remote Control Console, click Backup in the System Menu.

2  If you want to export a backup file to store it somewhere else, select the backup file from 
the list and click Download. When you are prompted to save or open the file, save it to the 
desired location. 

-Or-

If you want to import a backup file that was stored somewhere else, click Browse. Use the 
dialog box to navigate to and select the file. Click Upload. The file will be added to the list 
of available backups. 

Viewing System Information
The System Info section on the Remote Control web page allows you to view the server run 
time, a list of connected devices, the license server information, and local resources. 

To view the system information:

1  From the Remote Control web page, click System Info in the System Menu.

2  Select the tabs across the top to view different information.

Configuring Connection Profiles
Connection profiles allow you to define the skin displayed when a user connects to a device 
using Remote Control. They are configured from the  Remote Control Console.

The following options are available when configuring a connection profile:

Name The name of the connection profile.
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Use as 
default 

When this option is enabled, the current profile is used as the default when you 
establish a connection. 

If you want to establish a connection using a profile other than the default profile, 
you can set the profile from the viewer while you are connected.

Show 
skin

Displays a skin when you are connected to a device. When this option is enabled, the 
server is set to Autodetect and Remote Control will use device information to display 
the correct skin. 

NOTE:  If Remote Control settings are configured in a mobile device profile, the mobile 
device profile will override these connection profile settings. 

To configure the connection settings:

1  From the Remote Control Console, click Profiles in the User Menu. 

2  Select the connection profile from the Profiles list, or click Add New to create a new 
profile.

3  Configure the options are desired in the Details box. 

4  Click Save. 
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Chapter 5: Configuring the Remote Control Client
The Remote Control Client is configured from the Avalanche Console. After the package is 
added to a software profile, use the configuration tools in the package to modify the Remote 
Control Client or connect to the Remote Control Console. For information on launching the 
Remote Control Console from the package, see Using the Remote Control Console on page 11. 

The package can also be configured so that the Client can be configured from the device after 
it is installed. If the device user configures the Client, the user at the Avalanche Console still 
has the option to clear the settings. 

Certain Remote Control settings can also be configured from an Avalanche mobile device 
profile. When you configure Remote Control settings using a mobile device profile, the profile 
settings will override other Remote Control settings.  

This section provides information on the following topics:

• Editing the Remote Control Package

• Configuring Client Settings from the Mobile Device

• Clearing Client Settings

• Using a Mobile Device Profile for Remote Control Settings

Editing the Remote Control Package
Once the Remote Control server is installed and the package added to a software profile, you 
can configure the Remote Control Client with the server address, connection method, the 
logging level, and other client options. 

The following options are available when configuring the Remote Control package:

Connection Type Select to use either TCP/IP or ActiveSync to connect to mobile devices.

Server ID The ID for the server. This only needs to be modified if there are 
multiple Remote Control Servers. 

Server Address The DNS name or IP address of the Remote Control Server.

Server Port The port the Remote Control Server listens on.
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Connection Policy Select how Remote Control notifies the mobile device user that Remote 
Control is establishing a connection. 

• Silent indicates that the user will not be notified. 

• Notify indicates that the user will see a text window on his device 
letting him know that a connection has been established. 

• Prompt-Allow will provide the user with a prompt to allow or deny 
the connection. If the user does not respond, the connection will be 
allowed.

• Prompt-Deny will provide the user with a prompt to allow or deny 
the connection. If the user does not respond, the connection will be 
denied.

Policy Time Select how long the notification or prompt will be displayed. If you 
selected Prompt-Allow or Prompt-Deny, this is the number of seconds 
Remote Control will wait before establishing or denying the 
connection.

Log Level This is for the client log stored on the device. Logging levels include:

• Critical. Indicates errors that cause Remote Control to fail to start.

• Error. Indicates errors that are caused by configuration and/or 
communication problems.

• Informational. Documents the flow of operation.

• Warning. Indicates possible operational problems.

• Debug. Used to diagnose program malfunctions or communication 
problems.

Maximum Size Configure the maximum size that the log file can reach before creating 
a new log file. New log files do not override previous log files.

Password A password to require Remote Control users to provide a password 
before connecting to a mobile device.

Client Sleep 
While Connected

Allows the mobile device to enter sleep mode while connected to 
Remote Control. If you do not enable this option, Remote Control will 
not allow the mobile device to enter sleep mode while connected.
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Allow Client 
Configuration

Grants client configuration control to the mobile device user. This 
allows the user to configure the Remote Control client from the mobile 
device. When the mobile device user has configuration control, any 
changes you make in the Client Settings tab from the Remote Control 
Console will not deploy to the device. To regain Client Configuration 
setting control from the Remote Control Console, you must disable this 
option and redeploy the settings to the mobile device.

Disable Client Exit When this option is enabled, the mobile device user cannot exit the 
Remote Control application.

Client Pre-connect to 
Server

Configures the device to always pre-connect to the Remote Control 
Server.

Client Connect on 
ActiveSync

When this option is enabled, the device will attempt to connect to the 
server when it is cradled. 

Corporate Connection This determines if VPN or port forwarding will be used by the mobile 
device connecting to your server. 

• If this option is enabled, the mobile device uses a VPN connection 
to connect to the server. 

• If this option is disabled, the mobile device uses an Internet 
connection to connect to the server.

To edit the Remote Control package from the Java Console:

1  From the Profiles tab, select the software profile that has the Remote Control package.

2  In the Software Packages list, select the Remote Control package and click Configure.

The Configure Software Package dialog box appears.

3  Select Client Configuration from the list and click Launch.

The Remote Control Client Configuration dialog box appears.

4  Configure the options as desired.

5  Click OK to save your changes and return to the Java Console.

To edit the Remote Control package from the Web Console:

1  From the Profiles tab, click on the name of the software profile that has the 
Remote Control package.

The Software Profile Details page appears.

2  From the Software Package panel, click Configure for the Remote Control package.
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NOTE:  If you do not have Java installed locally, click Install Java in the Configure column. 
After installing Java, the Configure option will be available. 

3  Depending on your browser and security settings, you may be prompted to trust the 
Wavelink certificate. If you are prompted to select the program to use for opening the file, 
choose Java Web Start Launcher from the list and click OK.

4  The Configure Software Package dialog box appears. Click Next.

5  Select Client Configuration from the list and click Launch Config.

The Remote Control Client Configuration dialog box appears.

6  Configure the options as desired.

7  Click OK to return to the Configure Software Package dialog box. 

8  Click Next to save your changes.

9  Click Finish to return to the Web Console.

Configuring Client Settings from the Mobile Device
Before you can configure client settings from the mobile device, you must enable the Allow 
Client Configuration option from the Remote Control Console (in the Client tab of the Client 
Setup page). This allows the mobile device user to configure the connection type, policy 
notification, password, and whether the device is allowed to sleep while connected. If you 
disable the Allow Client Configuration option, the mobile device user will not be allowed to 
access the client information on the mobile device.

For more information about enabling the Allow Client Configuration option and the 
configurations available, see Editing the Remote Control Package on page 18.

NOTE:  Once you have configured the options from the device, the client will no longer 
accept configuration changes from Avalanche. In order to push settings to the device from 
Avalanche again, you should disable the Allow Client Configuration option or use the 
Clearing Client Settings on page 22 option.

The following settings are configurable from the device:

Connection 
Type

Select to use either TCP/IP or ActiveSync to connect to mobile devices.
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Policy Select how Remote Control notifies the mobile device user that Remote Control 
is establishing a connection. 

Silent indicates that the user will not be notified. 

Notify indicates that the user will see a text window on his device letting him 
know that a connection has been established. 

Prompt-Allow will provide the user with a prompt to allow or deny the 
connection. If the user does not respond, the connection will be allowed.

Prompt-Deny will provide the user with a prompt to allow or deny the 
connection. If the user does not respond, the connection will be denied.

Policy 
Seconds

Select how long the notification or prompt will be displayed. If you selected 
Prompt-Allow or Prompt-Deny, this is the number of seconds Remote Control 
will wait before establishing or denying the connection.

Password A password to require Remote Control users to provide a password before 
connecting to a mobile device.

Allow 
Sleep 
while 
connected

Allows the mobile device to enter sleep mode while connected to Remote 
Control. If you do not enable this option, Remote Control will not allow the 
mobile device to enter sleep mode while connected.

To configure client settings from the mobile device:

1  Launch the Remote Control application on the mobile device.

2  Tap File > Configure.

The Configure dialog box appears.

NOTE:  If the Allow Client Configuration option is not enabled from the Remote Control 
Console, the Not Available dialog box appears. The device user will not be able to access client 
settings. 

3  Configure the settings as desired.

4  Click OK.

The Remote Control client is updated with the new settings.

Clearing Client Settings
You can clear all client configuration settings using the Clear Client Settings option in the 
Standard Viewer. When you select this option, all your client configurations are removed, 
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including anything that was configured on the mobile device. This option is useful if you have 
enabled the Allow Client Configuration option. 

To clear client settings:

• From the Standard Viewer, click Tools > Clear Client Settings.

Using a Mobile Device Profile for Remote Control Settings
Configure Remote Control settings for a device by using a mobile device profile. The mobile 
device profile allows you to configure the following options for the Remote Control client:

Connection 
Policy

Select how Remote Control notifies the mobile device user that Remote 
Control is establishing a connection. 

Silent indicates that the user will not be notified. 

Notify indicates that the user will see a text window on his device letting him 
know that a connection has been established. 

Prompt-Allow will provide the user with a prompt to allow or deny the 
connection. If the user does not respond, the connection will be allowed.

Prompt-Deny will provide the user with a prompt to allow or deny the 
connection. If the user does not respond, the connection will be denied.

Policy Time The length of time that the notification or prompt will be displayed. If you 
selected Prompt-Allow or Prompt-Deny, this is the number of seconds 
Remote Control will wait before establishing or denying the session.

Log Level This is for the client log stored on the device. Logging levels include:

Critical. Indicates errors that cause Remote Control to fail to start.

Error. Indicates errors that are caused by configuration and/or communication 
problems.

Informational. Documents the flow of operation.

Warning. Indicates possible operational problems.

Debug. Used to diagnose program malfunctions or communication problems.

Maximum 
Size

Configure the maximum size that the log file can reach before creating a new 
log file. New log files do not override previous log files.
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Client Sleep 
While 
Connected

Allows the mobile device to enter sleep mode while connected to Remote 
Control. If you do not enable this option, Remote Control will not allow the 
mobile device to enter sleep mode while connected.

Allow Client 
Configuration

Grants client configuration control to the mobile device user. This allows the 
user to configure the Remote Control client from the mobile device. When the 
mobile device user has configuration control, any changes you make in the 
Client Settings tab from the Remote Control Console will not deploy to the 
device. To regain Client Configuration control from the Remote Control 
Console, disable this option and redeploy the settings to the mobile device.

Disable 
Client Exit

When this option is enabled, the mobile device user cannot exit the Remote 
Control application.

Client 
Pre-connect 
to Server

Configures the device to always pre-connect to the Remote Control Server.

Client 
Connect on 
ActiveSync

When this option is enabled, the device will attempt to connect to the server 
when it is cradled. 

Corporate 
Connection

This determines if VPN or port forwarding will be used by the mobile device 
connecting to your server. 

• If this option is enabled, the mobile device uses a VPN connection to 
connect to the server. 

• If this option is disabled, the mobile device uses an Internet connection to 
connect to the server.

Show Skin Displays a skin when you are connected to a device. When this option is 
enabled, select the skin you want to use from the drop-down menu. If you 
choose Autodetect, Remote Control will use device information to display the 
correct skin. 

NOTE:  When you configure Remote Control settings using a mobile device profile, the 
profile settings will override other Remote Control settings. 

To configure Remote Control settings using a mobile device profile:

1  Log in to the Avalanche Web Console. 

2  From the Profiles tab, click the name of the mobile device profile you want to configure.

The Mobile Device Profile Details page appears.

3  Enable the Manage Remote Control Settings option. 
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Mobile Device Profile Details

4  In the Remote Control Settings panel, configure the options as desired.

5  Save your changes.
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Chapter 6: Connecting to Mobile Devices
After you configure the client and server settings, deploy the  Remote Control client to the 
mobile device. Once the mobile device has the client installed, and you have added 
Remote Control licenses through Avalanche, you can create Remote Control connection 
sessions. A connection session is when the mobile device is connected to Remote Control, 
allowing you to view and control the mobile device. 

The Remote Control Client has an option to preconnect. When preconnect is enabled, the 
mobile device will automatically connect to the Remote Control Server without receiving a 
connection request. Then, when a user begins a connection session, the session begins quickly 
and easily because the device is already connected to the server. You can enable or disable 
preconnect from the Remote Control Console. 

When you have initiated a connection session, the device appears in a Remote Control Viewer. 
If you launch the viewer from the Avalanche Web Console, the connection session will appear 
in the Web Viewer. If you launch from the Avalanche Java Console or the Remote Control 
Console, the connection session will appear in the Standard Viewer. 

NOTE:  Device skins are not supported in the Web Viewer. They may appear, but they won't 
have any functionality.

This section provides information about the following Remote Control connection tasks:

• Connecting to a Mobile Device

• Closing Remote Control Sessions

• Standard Viewer Tasks

• Web Viewer Tasks

Connecting to a Mobile Device
A connection session can be initiated from the Avalanche Java Console or the Avalanche Web 
Console. 

When you initiate a connection session, the computer you are connecting from sends a request 
to the Remote Control Server. If the device is preconnected (has already established a 
connection to the server), the server connects the viewer to the device. If the device is not 
preconnected, the server requests the device to connect back to the server, and when the 
device responds the server connects the viewer to the device. Alternately, the Standard Viewer 
may try to connect to the device directly without routing traffic through the server. This 
option is only available when the device and viewer are on the same LAN. 
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NOTE:  If the device is not configured to preconnect, the device user can manually 
preconnect by opening the Remote Control Client and tapping File > Connect to Server.

To connect to a device from the Avalanche Java Console:

• From the Mobile Device Inventory tab, right-click the name of the device and select 
Remote Control from the context menu. 

-Or-

• From the Mobile Device Details dialog box, click the Device Control tab and then double-
click Remote Control. 

The WLRemoteControl dialog box appears while the viewer attempts to contact the device. 
When the Remote Control session has been initiated, the Standard Viewer appears. 
Clicking within the Standard Viewer sends the mouse click to the connected device. 
Typing on the physical keyboard sends the key commands to the mobile device.

To connect to a device from the Avalanche Web Console:

1  From the Inventory tab, click on the name of the device you want to connect to. 

The Mobile Device Details page appears.

2  In the Tools panel, click Remote Control. 

The Remote Control Web Viewer appears while the viewer attempts to contact the device. 
While the device is not connected, only the Status and Edit Device options will be 
available in the Available Commands panel. When the Remote Control session has been 
initiated, other commands will appears. Click View to open the device view and interact 
with the device. 

Closing Remote Control Sessions
When you close the window that the Standard Viewer appears in, the session is disconnected. 
The following are alternate methods to disconnect a connection session.

To close a connection session:

• From the Standard Viewer, select File > Exit.

-Or-

• From the Web Viewer, click Disconnect in the Available Commands panel. 
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Standard Viewer Tasks
This section provides information about using Remote Control once you are connected to a 
mobile device. The tasks detailed in this section assume you are connected to a mobile device. 

NOTE:  There are two different Viewer interfaces, depending on how you initiated the 
Remote Control connection. If you launched from the Avalanche Java Console, Remote 
Control will use the Standard Viewer. If you launched from the Avalanche Web Console, 
Remote Control will use the Web Viewer. You cannot connect to a device with both the 
Standard Viewer and the Web Viewer at the same time.

This section contains tasks for working from the Standard Viewer. For information on 
working from the Web Viewer, see Web Viewer Tasks on page 47. 

Once you connect to a mobile device, the Standard Viewer offers a variety of tools and 
configuration options. The Standard Viewer has the following tabs:

• Device. From this tab you can view the mobile device and perform operations on the 
mobile device. Clicking within the Standard Viewer sends the mouse click to the connected 
device. Typing on the keyboard sends the key commands to the mobile device.

• File System. From this tab you can access the file system on the mobile device. For detailed 
information about tasks you can perform in the File System tab, see Accessing the File 
System.

• Registry Viewer. The Registry Viewer allows you to view and edit the registry on the 
mobile device. For detailed information about the Registry Viewer, see Using the Registry 
Viewer.

• Processes. The Process Manager provides a view of the processes that are currently 
running on the mobile device. For detailed information, see Using the Process Manager.

• Access Log. The Remote Control logging feature stores information about the current 
connection session of Remote Control. For detailed information, see Accessing the Log File.

• Device Info. The Device Info tab provides information about the mobile device to which 
you are connected. For details about this tab, see Viewing Device Information.

The Standard Viewer has the following toolbar buttons:

Record. Begins to record a video. 
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Stop Record. Stops a video recording. 

Camera. Takes a picture of the current mobile device screen.

Toggle Skin. Toggles whether a skin for the device is displayed or not.

Refresh. Refreshes the mobile device screen.

Zoom in. Zooms in on the mobile device display.

Zoom out. Zooms out on the mobile device display.

Autoscale. Automatically scales the mobile device display to fit the size of the window 
you have open.

Set Video Mode. Allows you to set the video mode to Standard or Image. 

This section also provides information about the following Standard Viewer tasks:

• Configuring Display and Capture Options

• Using Device Tools

Accessing the File System

You can access the File Explorer of the mobile device using the Standard Viewer. This enables 
you to perform tasks and operations in the File Explorer on the mobile device from your 
Remote Control connection session. Access the File Explorer by opening the Standard Viewer 
clicking the File System tab. You can also access the File System from the Avalanche Mobile 
Device Details dialog box. Click the Device Control tab and then double-click the File System 
icon.

This section provides information about the following tasks from the Standard Viewer:

• Creating New Folders

• Copying Files to the PC

• Copying Files to the Mobile Device

• Manipulating Files on the Device

• Pasting Text
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Creating New Folders

You can create and name directories on the device using the File Explorer. 

To create a new folder on the device from the Standard Viewer:

1  Click on the File System tab.

2  Navigate to the location where you want to create the new folder.

3  Right-click and select New.

The folder is created in the selected location.

4  Right-click the new folder and select Rename Folder. 

5  Type the name of the folder.

Copying Files to the PC

You can copy files from the mobile device to the PC.

To copy files to the PC using the Standard Viewer:

1  Click on the File System tab.

2  Select the file or folder you want to copy to the PC. From the Files menu, select Copy to 
PC.

-Or-

Right-click the file you want to copy and select Copy to PC.

The Browse for Folder dialog box opens. 

3  Navigate to the location where you want to save the file.

4  Click OK.

The folder is copied to the selected location.

Copying Files to the Mobile Device

You can copy files from the machine running Remote Control and place them in the File 
Explorer of a connected mobile device.

To copy files to the mobile device using the Standard Viewer:

1  Click on the File System tab.

2  Navigate to where you want to place the file.

3  From the Files menu, select Copy to Remote.

The Open dialog box appears. 
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4  Locate the file that you want to copy to the mobile device and click Open.

The Sending Files Status dialog box appears. The files are copied to the selected location.

5  Once the file transfer is complete, click OK.

NOTE:  You can also drag files directly from the PC and drop them into the File Explorer. 

Manipulating Files on the Device

From the File Explorer, you can run, open, view or delete files located on the mobile device. 
You can run any file with an .exe extension. 

To run/open/view/delete a file on the mobile device from the Standard Viewer:

1  Click on the File System tab.

2  Using the tree view, navigate to the location of the file.

3  Right-click the file and select the desired option.

• If you are running a program, the program opens on the mobile device. 

• If you are opening a file, the file appears on the mobile device.

• If you are viewing a file, the file appears on the PC.

• If you are deleting a file, the file is removed from the list. 

4  Click the Device tab to view the mobile device screen.

Pasting Text

Remote Control allows you to copy and paste text from the PC to the mobile device. Only 
textual information can be copied and pasted. For example, you could copy text from a text 
editor on the PC to Pocket Word on the mobile device. Both text editors must be open.

Use the Paste to device command to paste information from the PC to the mobile device.

To copy and paste information using the Standard Viewer:

1  Open a text editor on both PC and the mobile device.

2  From the text editor on your PC, select the text to be copied and pasted.

3  Right-click and select Copy.

4  In the Standard Viewer, select Edit > Paste to device.

The text appears in the text editor on the mobile device. 
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Using the Registry Viewer

From the Registry Viewer tab in the Standard Viewer, you can browse and view the registry 
of a connected mobile device. Access the device's registry from the Standard Viewer by 
clicking the Registry Viewer tab. You can also access the Registry Viewer through the Mobile 
Device Details dialog box. Click the Device Control tab and then double-click the Registry 
Viewer icon.

This section provides information about the following Registry Viewer tasks:

• Creating New Registry Keys

• Creating Key Values

• Viewing Binary Data

• Modifying Key Values

• Editing Binary Data

• Deleting Key Values

• Exporting Registries

• Comparing Registries

Creating New Registry Keys

From the Registry Viewer tab, you can create new registry keys on the mobile device.

To create a new registry key using the Standard Viewer:

1  Open the Registry Viewer.

2  Navigate to where you want to create a new key.

3  Right-click and select New Key.

A New Key folder appears.

4  Right-click the New Key folder and select Rename.

5  Name the folder.

Creating Key Values

You can create String, Binary, DWORD, and Multi-String values in the mobile device registry.

To create key values using the Standard Viewer:

1  Open the Registry Viewer.

2  Navigate to where you want to create a new key.
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3  Right-click and from the menu that appears, select the key value you want create.

The value appears in the file list box.

Viewing Binary Data

For any registry key, you can display the binary data for that key.

To view binary data using the Standard Viewer:

1  Open the Registry Viewer.

2  Navigate to the location of the key you want to view.

3  Right-click the key and select Display Binary Data.

The Binary Data dialog box appears.

Binary Data 

4  Use the options in the Format area to display the data in Byte, Word or Dword format.

5  Click OK when you are finished.

Modifying Key Values

You can modify key values in the Registry Viewer tab of the Standard Viewer.

To modify key values using the Standard Viewer:

1  Click the Registry Viewer tab.

2  Navigate to the location of the key you want to edit.

3  Right-click the key and select Modify.

A dialog box appears according to what type of key you are modifying.
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• If you are modifying a String or Binary value, the Edit String dialog box appears.

• If you are modifying a DWORD key value, the Edit DWORD Value dialog box appears.

• If you are modifying a Multi-String value, the Edit Multi-String dialog box appears.

4  Using the configuration options available in each dialog box, edit the key value.

5  Click OK when you are finished.

The key value is modified.

Editing Binary Data

You have the ability to modify the binary data of each type of key value in the Registry 
Viewer tab of the Standard Viewer.

To modify binary data using the Standard Viewer:

1  Click the Registry Viewer tab.

2  Navigate to the location of the key you want to modify.

3  Right-click the key and select Modify Binary Data.

The Edit Binary Value dialog box appears.

Edit Binary Value

4  In the Value data text box, edit the binary value as desired.

5  Click OK when you are finished.
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Deleting Key Values

You can delete registry key values that you no longer need.

To delete key values using the Standard Viewer:

1  Click the Registry Viewer tab.

2  Navigate to the location of the key you want to delete.

3  Right-click the key and select Delete.

A dialog box appears asking you to confirm that you want to delete this key value.

4  Click Yes if you want to permanently delete the value.

The key value is removed from the registry.

Exporting Registries

You can export registries from the mobile device and save them as .xml files on your 
computer. 

To export a registry using the Standard Viewer:

1  Click the Registry Viewer tab.

2  Navigate to the location of the registry you want to export.

3  From the File menu, select Export.

A Save As dialog box appears.

4  Navigate to the location where you want to save the registry.

5  Name the registry and click Save.

The registry is saved as an .xml file.

Comparing Registries

There are two methods you can use to compare registries:

• You can compare the registry on a mobile device to a registry you have saved and 
exported. 

• You can compare the registry of one device to another device after establishing a second 
connection session.

To compare registries from the Standard Viewer:

1  Click the Registry Viewer tab.

2  From the File menu, select Compare.
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A dialog box appears.

 

3  If you are comparing it to a saved registry, select the Existing Registry option and click 
OK. In the dialog box that appears, navigate to the location of the registry to which you 
want to compare and click Open.

-Or-

If you are comparing it to the registry of another device, select Another Device and click 
OK. In the dialog box that appears, specify the connection type and IP address for the 
second device and click OK. 

A Registry Compare dialog box appears displaying the existing registry file.

4  When you are finished comparing registries, close the Registry Compare dialog box.

Using the Process Manager

The Processes tab in the Standard Viewer allows you to view the processes that are currently 
running on the mobile device. You have the option to activate or kill (end) any of the 
processes. Activating a process brings that process to the foreground of the device screen. 
Killing a process stops the process.

To use the Process Manager:

1  Click the Processes tab.
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Process Manager

2  Select a process and right-click to Activate or Kill that process.

Accessing the Log File

The Remote Control logging feature stores information about the connection sessions for 
Remote Control. 

This section provides information about the following logging options:

• Viewing and Clearing Log Files

• Configuring Logging

Viewing and Clearing Log Files

You can view the log file for a current Remote Control session from the Access Log tab. If you 
need to delete the information that displays in the log file, you can clear the entire file. When 
you select to clear the log file, the entire log in the Access Log tab is removed. You cannot 
select individual items to clear.
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To clear the log file:

1  Click the Access Log tab.

2  From the Edit menu, select Clear Log.

-Or-

Right-click within the log and select Clear Log.

The Access Log tab clears. 

Configuring Logging

Remote Control supports the following log levels:

• Critical. This level writes the least information to the log file, reporting only critical errors 
that cause a process to abort.

• Error. This level writes Error messages and Critical messages to the log file. 

• Warning. This level writes Critical messages, Error messages, and Warning messages to the 
log file. 

• Informational. This level writes enough information to the log file to diagnose most 
problems. 

• Debug. This logging level writes large amounts of information to the log file that can be 
used to diagnose more serious problems. 

You can change the logging for a particular connection session through the Configure dialog 
box located in the Standard Viewer. 

To change the logging configuration:

1  Click the Access Log tab.

2  From the File menu, select Configure.

The Configure dialog box appears.

3  In the Logging area, select the log level from the Level drop-down menu.

4  Enter the maximum size you want the log level to reach in the Max Size text box.

5  Click OK.

The Configuration Data Change dialog box appears. This dialog box indicates that you 
changed something from the original profile configuration.
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• If you want to use your updated changes, but do not want to update the configuration 
file, select the Use New Configuration option.

• If you want to use your updated changes and update the configuration file to reflect 
those changes, select the Use New Configuration and Update config file option.

6  Click OK.

The new logging information is applied.

NOTE:  You can also set up the logging configuration when you configure the Client. For 
more information, see   Editing the Remote Control Package on page 18.

Viewing Device Information

The Device Info tab in the Standard Viewer provides information about the mobile device to 
which you are connected. This information includes:

• Identification, including OEM information and the operating system versions.

• Memory, including the amount of free memory left on the device and storage space.

• Power, including information about the battery level and charging status of the mobile 
device.

• Screen, including information about the screen size and orientation.

• Security, including password information.

To view device information:

• From the Standard Viewer, click the Device Info tab.
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Device Info

Configuring Display and Capture Options

When you create a Remote Control connection session, you can configure the following 
display and capture options:

• Setting Video Mode

• Configuring Display Refresh Rates

• Sizing the Mobile Device Display

• Toggling Statistics

• Using Device Skins

• Recording Videos

• Performing Screen Captures
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Setting Video Mode

You can set two types of video mode depending on how you want the mobile device screen to 
appear and how fast you want the program to run.

• Standard Mode. This mode provides the clearest, most accurate screen images. However 
the refresh rate is slower over wide area connections.

• Image Mode. This mode provides faster screen updates with reduced image quality. You 
can set the screen display quality from one - 99 based on preference. 

To set video mode:

1  From the Standard Viewer, click the Video Mode icon.

The Set Video Mode dialog box appears.

Set Video Mode

2  Select the video mode you want to use and click OK.

Configuring Display Refresh Rates

You can configure the rate at which Remote Control refreshes the mobile device screen 
display. The refresh rate can range from 1 to 17 frames per second. Your selection is 
dependent on the speed of the mobile device and the communication method you are using. 
Select the best setting for your usage that does not impact the mobile device CPU too heavily 
and allows for reasonable screen updates.



42

NOTE:  You can also configure the refresh rate option when you configure the Client. For 
more information, see Editing the Remote Control Package on page 18.

To configure the refresh rate:

1  From the Standard Viewer, click File > Configure.

The Configure dialog box appears.

2  From the Refresh Rate drop-down list, select the rate at which you want the screen display 
to refresh.

3  Click OK.

The Configuration Data Change dialog box appears. This dialog box indicates that you 
changed something from the original profile configuration.

• If you want to use your updated changes, but do not want to update the configuration 
file, select the Use New Configuration option.

• If you want to use your updated changes and would like to update the configuration 
file to reflect those changes, select the Use New Configuration and Update config file 
option.

4  Click OK.

Sizing the Mobile Device Display

While you are viewing a device, you can configure the size of the mobile device display to 
scale from .5x - 4x. There is also an auto-scale option that will fit the display to the size of the 
window you have open. 

NOTE:  You can also configure scale setting when you configure the Client. For more 
information, see Editing the Remote Control Package on page 18.

To change the display scale:

• From the View Menu, select Scale and then the size you want the display to be.

-Or-

• Use the Zoom In, Zoom Out, or Autoscale toolbar options to adjust the size of the display.

To set the scale for the profile:

1  From the File menu, select Configure.

The Configure dialog box appears.

2  From the Scale drop-down list, select the size of the mobile device display.

3  Click OK.
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The Configuration Data Change dialog box appears. This dialog box indicates that you 
changed something from the original profile configuration.

• If you want to use your updated changes, but do not want to update the device 
configuration file, select the Use New Configuration option.

• If you want to use your updated changes and update the configuration file to reflect 
those changes, select the Use New Configuration and Update config file option.

4  Click OK.

The device will appear as the size you selected.

Toggling Statistics

You can display connection statistics at the bottom of the Standard Viewer. The statistics 
include bytes sent, bytes received, the number of keys pressed during the session, and the 
number of mouse clicks during the session.

To toggle statistics:

1  Click the Device tab.

2  From the View menu, select Toggle Statistics.

Using Device Skins

From the Standard Viewer, you can toggle between a selected skin and the default view (no 
skin). To use skins, you must enable the Show Skin option when you are configuring the 
Client or from the Configure dialog box in the Standard Viewer.

If you did not enable the Show Skin option when you configured the Client, you can 
configure the connection to display skins from the Standard Viewer.

NOTE:  For information on how to enable the Show Skin option, see Editing the Remote 
Control Package on page 18.

Once you enable the Show Skin option, Remote Control displays the skin for the connected 
mobile device. You can toggle the skin to display or not display from the Device tab in the 
Standard Viewer.

To enable the Show Skin option:

1  From the File, select Configure.

The Configure dialog box appears.

2  Enable the Show Skin option.

3  Select which skin to display from the Skin drop-down list.

4  Click OK.
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The Configuration Data Change dialog box appears. This dialog box indicates that you 
changed something from the original profile configuration.

• If you want to use your updated changes, but do not want to update the configuration 
file, select the Use New Configuration option.

• If you want to use your updated changes and would like to update the configuration 
file to reflect those changes, select the Use New Configuration and Update config file 
option.

5  Click OK.

The skin image appears in the Device tab of the Standard Viewer.

To toggle skins:

1  Select the Device tab in the Standard Viewer.

2  From the View menu, select Toggle Skin.

-Or-

Click the Toggle Skin icon in the Standard Viewer toolbar.

Recording Videos

You can record a video of your Remote Control session for training or demonstration 
purposes. First, you must enable AVI as the recording method. You can select the AVI 
recording method from the Configure dialog box in the Standard Viewer. You can play the AVI 
file using any program compatible with the AVI video file format, such as Windows Media 
Player.

To display the cursor while recording:

1  From the File menu, select Configure.

The Configure dialog box appears.

2  If you want the cursor to display in the AVI video, enable the Show Cursor option.

3  Click OK.

The Configuration Data Changed dialog box appears. This dialog box indicates that you 
changed something from the original profile configuration.

• If you want to use your updated changes, but do not want to update the configuration 
file, select the Use New Configuration option.

• If you want to use your updated changes and update the configuration file to reflect 
those changes, select the Use New Configuration and Update config file option.

4  Click OK.
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The new recording information is applied.

To record the AVI file:

1  In the Standard Viewer, click the Record toolbar icon.

The Save As dialog box appears.

2  Name the file and click Save.

The Video Compression dialog box opens.

3  Configure the compression options and click OK.

4  From the Device tab in the Standard Viewer, perform the actions on the mobile device that 
you want to record.

5  Click the Stop Record toolbar icon when you are finished.

The AVI file is saved in the directory specified.

Performing Screen Captures

When you are connected to a mobile device through a Remote Control session, you can 
capture screen images from the mobile device. 

Before you can take screen captures using Remote Control, you must select the method by 
which you want to capture the screen image. You can capture screen shots using three 
different methods:

• File. Use this option to save the image to a specified file. Once you capture the screen 
image, you can specify where you want to save the file.

• Clipboard. Use this option to place the image on the clipboard.

• One-click. Use this option to click once and send the screen capture to a previously 
specified file format. The file format must be chosen in the Configure dialog box. The file 
name will be automatically created based on the current time and date.

You can configure screen capture methods from the Standard Viewer. You can also configure 
screen capture methods when you configure the Client. For more information, see Editing the 
Remote Control Package on page 18. 

To configure the screen capture method:

1  In the Standard Viewer, select File > Configure.

The Configure dialog box opens.

2  In the Screen Capture area, select the method you want to use when performing screen 
captures.

3  Click OK.
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The Configuration Data Change dialog box appears. This dialog box indicates that you 
changed something from the original profile configuration.

• If you want to use your updated changes, but do not want to update the configuration 
file, select the Use New Configuration option.

• If you want to use your updated changes and update the configuration file to reflect 
them, select the Use New Configuration and Update config file option.

4  Click OK.

The screen capture method you configured is now enabled.

To perform a screen capture:

1  In the Device tab, navigate to the screen view of the device you want to capture.

2  Click the Camera toolbar icon.

The image is saved according to the screen capture method you configured in the Configure 
dialog box.

Using Device Tools

When you are connected to a device, Remote Control has several tools to help you control the 
device. These tools include:

• Soft Reset. Forces a warm boot on the device. When you reset the device, the Remote 
Control connection is terminated. 

• Suspend. Puts the mobile device in a suspended (sleep) state. When you suspend the 
device, the Remote Control connection is terminated.

• Clearing Client Settings. Clears changes to the Remote Control settings that the device 
user may have set. 

To use the device tools:

1  Click the Device tab.

2  From the Tools menu, select the tool you want to use.

If you select Soft Reset or Suspend, the connection session is terminated. 

If you select Clearing Client Settings, any Remote Control settings changed by the device 
user are reset.
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Web Viewer Tasks
This section provides information about using the Remote Control Web Viewer once you are 
connected to a mobile device. The tasks detailed in this section assume you are connected to a 
mobile device. For information about creating a connection session, see Connecting to Mobile 
Devices on page 26. 

NOTE:  There are two different Viewer interfaces, depending on how you initiated the 
Remote Control connection. If you launched from the Avalanche Java Console, Remote 
Control will use the Standard Viewer. If you launched from the Avalanche Web Console, 
Remote Control will use the Web Viewer. You cannot connect to a device with both the 
Standard Viewer and the Web Viewer at the same time.

This section contains tasks for working from the Web Viewer. For information on working 
from the Standard Viewer, see Standard Viewer Tasks on page 28. 

Once you connect to a mobile device, Remote Control offers a variety of functionality, tools 
and configuration options. The Web Viewer has the following tabs:

• Device. For information on tasks performed from the Device tab, see The Device Tab.

• Files. The Files tab allows you to view and modify the files on the device. You can run, 
open, download, rename, or delete files. For information on tasks performed from the Files 
tab, see Using the File Explorer.

• Registry. The Registry tab allows you to view and modify the device registry. For 
information on tasks performed from the Registry tab, see Using the Registry Explorer. 

• Processes. The Processes tab allows you to view, kill, and activate processes on the device. 
For information tasks performed from the Processes tab, see Using the Process Manager.

• Device Info. The Device Info tab provides information on the device ID, memory, power, 
screen, and security. You cannot change any of the information from this tab. For details 
on the information available on this tab, see Viewing Device Information.

• Scripts. The Scripts tab allows you to create scripts in JavaScript to run on your device 
using Remote Control. For more information on how to use the Script Editor, see the 
Remote Control Scripting Reference Guide on the Wavelink web site.

NOTE:  Skins may be displayed in the Web Viewer, but they will not be functional. 
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The Device Tab

The Device tab in the Web Viewer allows you to interact with the device and view its access 
history and logs. You can also perform tasks such as a reboot or device sync. The tab has four 
panels:  

Device Description Panel

The Device Description panel on the Web Viewer Device tab provides information about the 
device you are connected to, a thumbnail of the current display on the device, and buttons for 
updating or refreshing the thumbnail. Device information may include:

Status The connection status of the device.

OEM Info OEM info as reported by the device. 

Server Address Address for the Avalanche Mobile Device Server.

Ava Term ID Terminal ID assigned to the device by Avalanche.

Last Seen Last time the device was  connected to.

Description Device description set in Remote Control Console. 

IP Address IP address of the mobile device.

Phone Number Phone number for the device.

Carrier Carrier for the device’s phone service.

Available Commands Panel

The following commands are performed from the Available Commands panel on the Device 
tab:

View Opens a real-time view of the device in a new tab or window. 

Status Displays information about the connection status. When you click Status, the 
Device Status dialog box appears. This dialog box allows you to refresh the status 
of the device, disconnect, reboot, or ping the device, or display the Remote 
Control Client interface on the device. 

Edit 
Device

Allows you to edit the device description details, including the phone number, 
carrier, name and description.

Disconnect Disconnects the device from the Remote Control session. 
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Reboot Performs a warm boot of the device. The connection session is terminated.

Suspend Sends the device into a suspended (sleep) state. The connection session is 
terminated. 

Text 
Message

Sends an SMS text message to the mobile device.

Device 
Sync

Sends an SMS message to the device requesting it to connect to the Avalanche 
Mobile Device Server.

Device Log Panel

The Device Logs panel displays Remote Control logged activity for the device. This includes 
the time of the activity, the user who performed the action, whether the action was successful, 
and possible additional information. 

Access History Panel

The Access History Panel displays Remote Control connection history for the device. This 
includes the time of the activity, the user who attempted to connect, the IP address the 
Avalanche user connected from, and the access type for the connection. 

Using the File Explorer

You can access the File Explorer of the mobile device from your PC during your Remote 
Control connection session. This enables you to view, copy, rename, or delete files and 
perform tasks on the mobile device.

To use the File Explorer:

1  From the Avalanche Web Console, navigate to the Mobile Device Details page and click File 
Explorer.

-Or-

After you have established a Remote Control session with the device, click the Files tab in 
the Web Viewer.

2  Use the folder icons to navigate to the desired file. 

• When you select the file, the file information appears in a panel above the File Explorer, 
and you have the options to Run, Open, Download the file from the mobile device, 
Rename, or Delete. 

• To copy a file to the device, navigate to the location you want the file stored and click 
Upload File. When the Uploading Files area appears, click Browse to find the file you 
want to copy to the device. After selecting the file, click Upload. 
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• Use the Add Directory and Delete Directory options to change the file structure. 

Remote Control will make the changes on the device as you perform the desired tasks.

Using the Registry Explorer

From the Registry tab in the Web Viewer, you can view and edit the registry of a connected 
mobile device. 

To view and edit the registry:

1  From the Avalanche Web Console, navigate to the Mobile Device Details page and click 
Registry Explorer.

-Or-

After you have established a Remote Control session with the device, click the Registry tab 
in the Web Viewer.

2  Use the tree view to navigate to the registry key you want to view or edit. 

• If you are adding or deleting a registry key, click Add Key or Delete Key at the top of 
the panel. 

• If you are editing a current value, select the name of the key and the Editing Registry 
Value panel appears. Make changes as desired and click Save.

• If you are adding a value, click Add New Value and the Adding Registry Value panel 
appears. Make changes as desired and click Save. 

Remote Control will make the changes on the device as you perform the desired tasks.

Using the Process Manager

The Processes tab in the Web Viewer allows you to view the processes that are currently 
running on the mobile device. You have the option to activate or kill (end) any of the 
processes. Activating a process brings that process to the front of any other programs 
running on the mobile device. Killing a process stops the process.

To use the Process Manager:

• From the Avalanche Web Console, navigate to the Mobile Device Details page and click 
Process Manager.

-Or-

• After you have established a Remote Control session with the device, click the Processes 
tab in the Web Viewer.

• To kill a process, select it from the list and click Kill.

• To activate a process, select it from the list and click Activate.
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Remote Control will make the changes on the device as you perform the desired tasks.

Viewing Device Information

The Device Info tab in the Web Viewer provides information about the mobile device to 
which you are connected. This information includes:

• Identification, including OEM information and the operating system versions.

• Memory, including the amount of free memory left on the device and storage space.

• Power, including information about the battery level and charging status of the mobile 
device.

• Screen, including information about the screen size and orientation.

• Security, including password information.

To view device information:

• After you have established a connection, click the Device Info tab in the Web Viewer.
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Chapter 7: Managing Device Skins
Skins display an image of the mobile device in the Standard Viewer. To reduce the size of the 
software package, Remote Control is only packaged with a select number of device skins. 
However, a variety of device skins from major manufacturers is available from the Skin 
Download Manager on the Wavelink web site. You also have the option of creating a new 
skin. 

Using the Skins Editor, you can import skin images you download or create and then assign 
keymaps to the skins. You can then configure Remote Control to detect what type of device 
you are connecting to and automatically display the associated skin. The Skins Editor is 
installed separately. For information on installing it, see Installing the Remote Control Skins 
Editor on page 6.

Keymaps allow you to use the skin, or image of the mobile device, just as you would if you 
were pressing the buttons on the actual device. The keymaps assign specific functions to each 
key on the image of the mobile device. You have the ability to create custom keymaps for any 
of your mobile devices.

NOTE:  Device skins and keymaps are only available with the Standard Viewer.

This section provides information about the following tasks:

• Accessing the Skins Editor

• Downloading Skins

• Creating and Editing Skins

• Packaging Skins

• Applying Skins

Downloading Skins
The Skin Download Manager has mobile device skins that you can download to the Skins 
Editor and use in Remote Control. These skins may be created by Wavelink or other Remote 
Control users. Users can create skins and then upload them to the Web site for other people to 
download. For information about packaging a skin you created and uploading it to the Skin 
Download Manager, see Packaging Skins on page 61. 

When you download a skin from the Skin Download Manager, the skins are stored on the 
Remote Control Server and also appear in the Skins List of the Skins Editor. 

To download skins:

1  From the Skins Editor, click Skin > Download From Web.



Chapter 7: Managing Device Skins 53

The Skins Download dialog box appears.

Skins Download

2  Click Connect.

You will connect to the Wavelink Skin Download Manager.
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Skins Download

3  Click on the name of the skin you want to download.

NOTE:  For each skin, there may be a number of different keyboard configurations. Be sure 
to select the skin with the keyboard configuration matching your device.

The skin files are downloaded to the \Skins folder in the Remote Control installation 
directory. The skin will appear in the skin list of the Skins Editor.

4  When you are done downloading skins, click OK. 

Once you download a skin, it is immediately visible to Remote Control, the Remote Control 
Console and the Skins Editor. You can open the skin from the list of skins.

Accessing the Skins Editor
The Skins Editor is installed separately from the Remote Control server or package. Once it is 
installed, it is accessed through the Windows Start menu.

The Skins Editor allows you to split the preview screen. Using the split preview screen, you 
can view different images of the mobile device skin at the same time. For example, you can 
view the color map in one screen and the actual device buttons in another.
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To access the Skins Editor:

• Click Start > Programs > RC Skins Editor 4.1 > Skins Editor.

To view split screen:

• From the View menu, select Split Device View.

Split Screen

Creating and Editing Skins
In order to create a new skin, you must complete the following tasks:

1  Create an image of the mobile device. Using a camera and/or graphics design program, 
create an image of the mobile device. This will be the image that appears when you connect 
to the mobile device and display the skin.
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2  (Optional) Create a down image of the mobile device. Using a graphics design program, 
create an image of the mobile device when a key is in a down state. The down image can be 
the same as the main image. 

3  Create a keymap image. Using a graphics design program, create a keymap for the mobile 
device keys/buttons you want to configure in the Skins Editor. The keymap assigns a 
unique color to each button area of the skin, and then the color is associated with a button 
action when you configure the skin. The keymap image should be the same size as the 
device image. 

Part of a keymap image

NOTE:  All image files should be saved as .png or .bmp. 

4  Create a new skin. Create a new skin in the Skins Editor by clicking Skin > New.

5  Import each image into the Skins Editor. When the images are imported, the Skins Editor 
can display the images, as well as a composite image of the device overlaid with the 
keymap. For information on importing the skin images, see Importing Images on page 57.

6  Configure the skin details. The Skins Editor allows you to configure the size and position 
of the screen and the actions for each button. For information on configuring the skin 
information, see Configuring Skin Information on page 58.

7  Create key states. Key states define how keys behave when the user presses keys such as 
SHIFT, CTRL, or ALT. For information on creating key states, see Creating Key States on 
page 59. 

8  Edit key details. Define what each key press will do. This includes defining which keys 
toggle key states and multi-click key options. For information on editing key details, see 
Configuring Key Actions on page 60.
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Importing Images

Import the images you created of the mobile device into the Skins Editor. Imported images will 
be available to display in the Standard Viewer when you connect to a mobile device. You can 
import the following types of images:

• Normal. This image is the normal display of the mobile device when it is in a stand-by 
state. This image displays upon a Remote Control connection to the mobile device.

• Down. This image displays the mobile device when a key is in the down state. This image 
can be the same as the normal image.

• Map. This image is the keymap for the mobile device. The image should display all the 
buttons that you want to configure for the mobile device as a unique color button. You use 
this image to map an action for each key. For an example of a map image, see Accessing the 
Skins Editor on page 54.

As you import each image, Normal, Down, and Map tabs appear in the preview area. You can 
click each tab to display the specific image. When you are finished importing, an Overlay tab 
appears. Use this tab to compare the Map image to the Normal (actual) image of the mobile 
device. You can verify that the buttons on the map image match up with the buttons on the 
mobile device image. 

To import images:

1  From the device list in the Skins Editor, select the device for which you want to import 
images.

2  Click the [...] button to the right of the Normal Image text box.

3  Locate the image file you want to import and click Open.

The image displays in the Normal tab.

4  Click the [...] button next to the Down text box.

5  Locate the image file you want to import and click Open.

The image displays in the Down tab.

6  Click the [...] button next to the Map text box.

7  Locate the image file you want to import and click Open.

The image displays in the Map tab.

8  Click Apply Changes to save your changes.
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Configuring Skin Information

Create a new skin file before importing skin images. The skin file contains the device 
information for that specific skin.  Remote Control uses this information to detect the type of 
device it is connecting to and then displays the appropriate skin.

You can configure the following types of skin information:

• Extended Skin. Extended skins are skins that have configured keymaps. If you are not 
going to configure a keymap for this skin, do not enable this option.

• Name. This is the name of the skin.

• OEM Info. This may be the complete OEM string returned by the device or a partial 
string. Remote Control will match the complete OEM string, returned by the device, with 
the data entered here. For example, if a device returns “My Device 3100” and another 
device returns “My Device 3110”, a skin with the OEM String “My Device 31” would match 
both. This is useful when similar devices can share the same keyboard information and 
slight display differences are not significant.

• Client Screen (X and Y coordinates). These coordinates reflect the height and width that 
the skin will display in the Standard Viewer.

• Screen Size (Width and Height). If two similar devices return the same OEM but have 
different screen sizes, you can specify the screen size for this skin so that Remote Control 
will auto detect the correct skin. 

NOTE:  A GUID is automatically assigned to the skin. You cannot configure this information.

To configure skin information:

1  From the Skins menu, select New.

2  In the device information area, enable the Extended Skin option if you are creating an 
extended skin.

3  In the Name text box, enter the name of the skin.

4  In the OEM Info text box, enter device manufacturer information you want the Remote 
Control auto-detect feature to associate this skin with. 

5  In the Client Screen text boxes, enter the pixel height and width for the skin image for the 
device. 

6  In the Screen Size text boxes, enter the pixel height and width for the screen.

7  Click Apply Changes to save your changes.



Chapter 7: Managing Device Skins 59

Once you enter information for the mobile device, you are ready to import the images of 
the device that you have created.

Creating Key States

Using key states, you can create many different actions for each mobile device key. For 
example, you can configure a key to send "a" in the normal state and "A" in a CAPS LOCK 
state. This allows multiple uses for the same keys. 

You also have the option of making each key a multi-click key. This means that in one state, a 
key can perform up to four different actions depending on the number of times it is pressed.

Each state can be defined as a sticky state. When a state is sticky, it will persist until the user 
changes the state again. If the state is not set to be sticky, then after another key is pressed, the 
device will be reset to the default state. (For example, CAPS LOCK is a sticky state that persists 
until the user switches the state. SHIFT normally changes the state until a key is pressed and 
then the device goes back to the default state.) 

To create new device states:

1  In the Actions Editor area, click New.

The New State dialog box appears.

New State

2  Enter a name for the state.

3  Enable the Default option if you want this state to be the default state the keys are in when 
displayed in the Standard Viewer.

4  Enable the Sticky option if you want this state to be sticky.

5  Click OK when you are finished.

The new state appears as a tab in the Actions Editor area. 
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Configuring Key Actions

You can configure key behavior for each button you created in your keymap image for the 
mobile device skin. The key can be configured differently depending on the state the device is 
in or how many times the key is pressed. Keys can also be configured to toggle the state of the 
device.

To configure key actions:

1  After you have imported the device image and keymap image into the Skins Editor, click 
on the key you want to configure. (You can click on the key from any of the device 
views: Normal, Down, Map, or Overlay.) 

The Edit Key Detail dialog box appears.

Edit Key Detail

2  Enter a Tooltip for the key. The information you enter into the Tooltip text box will 
display in the Standard Viewer when you move the mouse over that key.

3  Each key state you have created appears as a tab. Each tab defines what happens when the 
key is pressed while the device is in that state. 

4  From the On Click drop-down list, select the action you want this key to perform on the 
first click. You can also enter the code for the action you want the key to perform in the 
Code text box.
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• If you want the key to be a multi-click key, enable the Multi Click option and 
configure the On Click 2, On Click 3 and On Click 4 options using the drop-down 
lists.

• If you want this key to toggle the state of the mobile device (for example, act as the shift 
key), enable the Toggle option and type the name of the state that you want the device 
to switch to in the Code text box.

5  Continue configuring the key for all the states.

6  When you are finished, click OK.

The key is now assigned to perform the actions you configured. 

7  Click Apply Changes to save the key configuration.

Packaging Skins
Only a certain number of skins are included with the Remote Control software package. 
However, you can access and import other skins with the Wavelink web site Skins Download 
Manager. Additionally, if you create new skins for mobile devices, you can package the skins 
and upload them to the Wavelink Web site for other Remote Control users to access.

To package skins:

1  In the Skins list, select the skin you want to send to Wavelink.

2  From the Skin menu, select Send to Wavelink.

The Upload Skins Package to Wavelink dialog box appears.
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Upload Skins Package to Wavelink

3  Enter your name, company and e-mail in the appropriate text boxes.

4  Add any comments about the skin you are sending in the Comments text box.

5  Click OK.

Remote Control packages all the files used to create the selected skin and send the package 
to Wavelink. Wavelink then posts the skin on the Skins Download Manager, allowing other 
Remote Control users to download it.

Applying Skins
You can apply or change a skin from either the Web Viewer or the Standard Viewer when you 
are connected to a mobile device.

NOTE:  You can also set a default skin from the Remote Control Console or from an 
Avalanche mobile device profile. For more information, see Configuring Connection Profiles 
on page 16 or Using a Mobile Device Profile for Remote Control Settings on page 23. When 
you have configured a skin using a mobile device profile, the profile settings will override 
other Remote Control settings. 

To apply a skin while you are connected with the Web Viewer:

1  From the Device tab of the Web Viewer, click Edit Device in the Available Commands 
panel.

2  Click Assign New.
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3  The Select a profile dialog box appears.

4  Click the name of the connection profile with the desired skin from the list.

5  Click Save.

6  The skin will appear when you view the device.

To apply a skin while you are connected with the Standard Viewer:

1  From the File menu in the Standard Viewer, select Configure.

The Configure dialog box opens.

2  Enable the Show Skin option.

3  From the Skin drop-down list, select which skin you want to display.

If you select Autodetect, Remote Control attempts to detect the type of device you are 
using and apply that skin.

4  Click OK.

The Configuration Data Changed dialog box appears. This dialog box indicates that you 
changed something from the original profile configuration.

Configuration Data Changed

• If you want to use the updated changes, but do not want to update the configuration 
file, select the Use New Configuration option.

• If you want to use the updated changes and would like to update the configuration file 
to reflect those changes, select the Use New Configuration and Update config file 
option.

5  Click OK.

The selected skin displays in the Standard Viewer.
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Ports List
The following table provides information about the default ports used with Remote Control 
and Avalanche.

Usage Port Type RC Server Console/ 
Viewer

RC 
Client

Contacting a mail server 
(Optional) 

251

1102

TCP Out N/A N/A

Device Connection3 1899 TCP In/Out Out In/Out

Server Control 1900 TCP In Out N/A

Status Checks 1903 UDP Out Out In

Avalanche License Server 7221 TCP Out N/A N/A

Avalanche Tomcat Server 8080 TCP Out N/A N/A

Avalanche Database 54324 TCP Out N/A N/A

1For SMTP.
2For POP3.
3For Avalanche On Demand or WAN connections, this port must be forwarded from the public IP to the internal server address.
4This is the default port for a PostgreSQL database. If you are using a custom port for PostgreSQL or if you are using Oracle or MS 

SQL Server, contact your database administrator for the port number.
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Wavelink Contact Information
Visit our web site at www.wavelink.com. If you have comments or questions regarding this 
product, please contact Wavelink Customer Service.

E-mail Wavelink Customer Support at: CustomerService@wavelink.com

For customers within North America and Canada, call the Wavelink Technical Support line at 
801-316-9000 (option 2) or 888-699-9283.

For international customers, call the international Wavelink Technical Support line at +800 9283 
5465.

For Europe, Middle East, and Africa, hours are 9 AM - 5 PM GMT. 

For all other customers, hours are 7 AM - 7 PM MST.
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